summaryrefslogtreecommitdiff
path: root/gnu/packages/ghostscript.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-07-16 23:09:37 -0400
committerLeo Famulari <leo@famulari.name>2018-07-17 20:44:52 -0400
commita1e3da63cb4b9a9151849d1d4360c2a8415becb5 (patch)
tree679cf46abc09e423252121fa214665772d5ca1a9 /gnu/packages/ghostscript.scm
parent276598b69b2003a1b153aaffba5200139f97a66e (diff)
downloadguix-patches-a1e3da63cb4b9a9151849d1d4360c2a8415becb5.tar
guix-patches-a1e3da63cb4b9a9151849d1d4360c2a8415becb5.tar.gz
gnu: ghostscript: Fix CVE-2018-10194.
* gnu/packages/ghostscript.scm (ghostscript)[replacement]: New field. (ghostscript/fixed): New variable. * gnu/packages/patches/ghostscript-CVE-2018-10194.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/ghostscript.scm')
-rw-r--r--gnu/packages/ghostscript.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/ghostscript.scm b/gnu/packages/ghostscript.scm
index 0a6043ba65..1240b1dc16 100644
--- a/gnu/packages/ghostscript.scm
+++ b/gnu/packages/ghostscript.scm
@@ -132,6 +132,7 @@ printing, and psresize, for adjusting page sizes.")
(define-public ghostscript
(package
(name "ghostscript")
+ (replacement ghostscript/fixed)
(version "9.23")
(source
(origin
@@ -250,6 +251,16 @@ output file formats and printers.")
(home-page "https://www.ghostscript.com/")
(license license:agpl3+)))
+(define-public ghostscript/fixed
+ (hidden-package
+ (package
+ (inherit ghostscript)
+ (source
+ (origin
+ (inherit (package-source ghostscript))
+ (patches (append (origin-patches (package-source ghostscript))
+ (search-patches "ghostscript-CVE-2018-10194.patch"))))))))
+
(define-public ghostscript/x
(package/inherit ghostscript
(name (string-append (package-name ghostscript) "-with-x"))