summaryrefslogtreecommitdiff
path: root/gnu/packages/ghostscript.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2017-05-02 03:41:24 -0400
committerMark H Weaver <mhw@netris.org>2017-05-02 04:19:11 -0400
commit7020a6ab8b8678e148d01814fa8c750743681c4e (patch)
tree084b3bfc69e17dcd5105f827ec10476a9fd9a787 /gnu/packages/ghostscript.scm
parentbedba064267490f2d9f7ee44e5ec103aacc82611 (diff)
downloadguix-patches-7020a6ab8b8678e148d01814fa8c750743681c4e.tar
guix-patches-7020a6ab8b8678e148d01814fa8c750743681c4e.tar.gz
gnu: ghostscript: Fix grafting of ghostscript/x and ghostscript/cups.
* gnu/packages/cups.scm (ghostscript/cups): Use package/inherit. * gnu/packages/ghostscript.scm (ghostscript/x): Use package/inherit. (ghostscript/fixed)[replacement]: Override to #f.
Diffstat (limited to 'gnu/packages/ghostscript.scm')
-rw-r--r--gnu/packages/ghostscript.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/ghostscript.scm b/gnu/packages/ghostscript.scm
index 5340107f99..4e8736cd71 100644
--- a/gnu/packages/ghostscript.scm
+++ b/gnu/packages/ghostscript.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
-;;; Copyright © 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2014, 2015, 2016, 2017 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2013, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2017 Alex Vong <alexvong1995@gmail.com>
@@ -209,8 +209,7 @@ output file formats and printers.")
(properties '((upstream-name . "gnu-ghostscript")))))
(define-public ghostscript/x
- (package (inherit ghostscript)
- (replacement #f)
+ (package/inherit ghostscript
(name (string-append (package-name ghostscript) "-with-x"))
(inputs `(("libxext" ,libxext)
("libxt" ,libxt)
@@ -219,6 +218,7 @@ output file formats and printers.")
(define ghostscript/fixed
(package
(inherit ghostscript)
+ (replacement #f)
(source
(origin
(inherit (package-source ghostscript))