summaryrefslogtreecommitdiff
path: root/gnu/packages/ghostscript.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2016-10-13 05:53:07 -0400
committerMark H Weaver <mhw@netris.org>2016-10-13 05:53:07 -0400
commit061d7f3bd2cc67c964acb2cb1bde07ee61df5d1a (patch)
tree5b22d1081972956d9190c94a7cc2b271d5f85d67 /gnu/packages/ghostscript.scm
parentf2ec23d18e50eef3e4f574a3e6498d8964e4e1a3 (diff)
parent1cc213850a2009d55e137fee990f9743894c76c5 (diff)
downloadguix-patches-061d7f3bd2cc67c964acb2cb1bde07ee61df5d1a.tar
guix-patches-061d7f3bd2cc67c964acb2cb1bde07ee61df5d1a.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/ghostscript.scm')
-rw-r--r--gnu/packages/ghostscript.scm19
1 files changed, 17 insertions, 2 deletions
diff --git a/gnu/packages/ghostscript.scm b/gnu/packages/ghostscript.scm
index 8f10b18074..fcf769fb35 100644
--- a/gnu/packages/ghostscript.scm
+++ b/gnu/packages/ghostscript.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
-;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2013, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
;;;
@@ -127,6 +127,7 @@ printing, and psresize, for adjusting page sizes.")
(package
(name "ghostscript")
(version "9.14.0")
+ (replacement ghostscript/fixed)
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/ghostscript/gnu-ghostscript-"
@@ -197,8 +198,22 @@ output file formats and printers.")
(license license:agpl3+)
(home-page "http://www.gnu.org/software/ghostscript/")))
+(define ghostscript/fixed
+ (package
+ (inherit ghostscript)
+ (replacement #f) ; Prevent ghostscript/x from inheriting the replacement
+ (source (origin
+ (inherit (package-source ghostscript))
+ (patches (search-patches "ghostscript-CVE-2013-5653.patch"
+ "ghostscript-CVE-2015-3228.patch"
+ "ghostscript-CVE-2016-7976.patch"
+ "ghostscript-CVE-2016-7978.patch"
+ "ghostscript-CVE-2016-7979.patch"
+ "ghostscript-CVE-2016-8602.patch"
+ "ghostscript-runpath.patch"))))))
+
(define-public ghostscript/x
- (package (inherit ghostscript)
+ (package (inherit ghostscript/fixed)
(name (string-append (package-name ghostscript) "-with-x"))
(inputs `(("libxext" ,libxext)
("libxt" ,libxt)