summaryrefslogtreecommitdiff
path: root/gnu/packages/gettext.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-07-27 10:20:23 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-07-27 10:20:23 +0200
commitdd54d3d5dafefc5845cec118538d1e07469ca8b3 (patch)
tree5c3f5746931fec901b8dc3e02a35740d66782ec1 /gnu/packages/gettext.scm
parentd39238cf3d71abaacb57317499692217bf24235c (diff)
downloadguix-patches-dd54d3d5dafefc5845cec118538d1e07469ca8b3.tar
guix-patches-dd54d3d5dafefc5845cec118538d1e07469ca8b3.tar.gz
gnu: po4a: Work around "dotless @INC" build issues.
* gnu/packages/gettext.scm (po4a)[arguments]: Add build phase "set-search-path".
Diffstat (limited to 'gnu/packages/gettext.scm')
-rw-r--r--gnu/packages/gettext.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/gettext.scm b/gnu/packages/gettext.scm
index 44535859cb..76c01b1e09 100644
--- a/gnu/packages/gettext.scm
+++ b/gnu/packages/gettext.scm
@@ -144,6 +144,13 @@ translated messages from the catalogs. Nearly all GNU packages use Gettext.")
(arguments
`(#:phases
(modify-phases %standard-phases
+ (add-before 'configure 'set-search-path
+ (lambda _
+ ;; Work around "dotless @INC" build failure.
+ (setenv "PERL5LIB"
+ (string-append (getcwd) ":"
+ (getenv "PERL5LIB")))
+ #t))
;; FIXME: One test fails as we don't have SGMLS.pm
(add-before 'check 'disable-sgml-test
(lambda _