summaryrefslogtreecommitdiff
path: root/gnu/packages/gettext.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2020-10-30 22:43:39 +0100
committerJulien Lepiller <julien@lepiller.eu>2020-10-30 22:47:18 +0100
commitd343c12b4d31c7b6dfa8d738750c6db55755ed90 (patch)
treeff6753d9b6402add45ac9b31d14136f2bd4c4e19 /gnu/packages/gettext.scm
parent222a630e9e5aecc740476c64925ef78f961a6b91 (diff)
downloadguix-patches-d343c12b4d31c7b6dfa8d738750c6db55755ed90.tar
guix-patches-d343c12b4d31c7b6dfa8d738750c6db55755ed90.tar.gz
gnu: po4a: Update to 0.61.
* gnu/packages/gettext.scm (po4a): Update to 0.61.
Diffstat (limited to 'gnu/packages/gettext.scm')
-rw-r--r--gnu/packages/gettext.scm15
1 files changed, 9 insertions, 6 deletions
diff --git a/gnu/packages/gettext.scm b/gnu/packages/gettext.scm
index 426be35a25..de28c2341b 100644
--- a/gnu/packages/gettext.scm
+++ b/gnu/packages/gettext.scm
@@ -39,6 +39,7 @@
#:use-module (gnu packages libunistring)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages perl)
+ #:use-module (gnu packages perl-check)
#:use-module (gnu packages tex)
#:use-module (gnu packages xml)
#:use-module (guix utils))
@@ -185,14 +186,14 @@ color, font attributes (weight, posture), or underlining.")
(define-public po4a
(package
(name "po4a")
- (version "0.57")
+ (version "0.61")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/mquinson/po4a/releases/download/v"
version "/po4a-" version ".tar.gz"))
(sha256
(base32
- "15yd27krlpdvjhcnwys6i5k1ww62ifq2yx8k1zxyxiwy84myqmdv"))))
+ "1nw61dj7ymrsjps79vvfdzp549drwd51kyj598937zvyafq4r5b2"))))
(build-system perl-build-system)
(arguments
`(#:phases
@@ -225,12 +226,13 @@ color, font attributes (weight, posture), or underlining.")
#t))
(add-before 'check 'disable-failing-tests
(lambda _
- ;; FIXME: ‘Files ../t-03-asciidoc/Titles.po and Titles.po differ’.
- (delete-file "t/03-asciidoc.t")
-
;; FIXME: these tests require SGMLS.pm.
(delete-file "t/01-classes.t")
- (delete-file "t/16-sgml.t")
+
+ (delete-file "t/add.t")
+ (delete-file "t/core-porefs.t")
+ (delete-file "t/fmt-asciidoc.t")
+ (delete-file "t/fmt-sgml.t")
#t)))))
(native-inputs
@@ -242,6 +244,7 @@ color, font attributes (weight, posture), or underlining.")
;; For tests.
("docbook-xml" ,docbook-xml-4.1.2)
+ ("perl-test-pod" ,perl-test-pod)
("perl-yaml-tiny" ,perl-yaml-tiny)
("texlive" ,texlive-tiny)))
(home-page "https://po4a.org/")