summaryrefslogtreecommitdiff
path: root/gnu/packages/gettext.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-11-18 21:11:49 +0100
committerAndreas Enge <andreas@enge.fr>2013-11-18 21:11:49 +0100
commitc42a4b76c400fd8cf30e145061637c70a2b12a02 (patch)
tree1fe8b078500799e31d69e2256ebbcd577bd2fd99 /gnu/packages/gettext.scm
parenta7bf595fffd3db97b14ab3d5a5703497de266cb9 (diff)
downloadguix-patches-c42a4b76c400fd8cf30e145061637c70a2b12a02.tar
guix-patches-c42a4b76c400fd8cf30e145061637c70a2b12a02.tar.gz
gnu: gettext: Enable "xgettext --language=glade".
* gnu/packages/gettext.scm (gettext): Add input expat, explicitly link with it.
Diffstat (limited to 'gnu/packages/gettext.scm')
-rw-r--r--gnu/packages/gettext.scm15
1 files changed, 12 insertions, 3 deletions
diff --git a/gnu/packages/gettext.scm b/gnu/packages/gettext.scm
index b6ea3a3f10..7edbfa023c 100644
--- a/gnu/packages/gettext.scm
+++ b/gnu/packages/gettext.scm
@@ -17,11 +17,12 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages gettext)
- #:use-module (guix licenses)
+ #:use-module ((guix licenses) #:select (gpl3))
#:use-module (gnu packages)
#:use-module (guix packages)
#:use-module (guix download)
- #:use-module (guix build-system gnu))
+ #:use-module (guix build-system gnu)
+ #:use-module (gnu packages xml))
(define-public gettext
(package
@@ -35,8 +36,16 @@
(base32
"0p940zmmw1lndvdhck2vrazikjhr02affwy47mmpfxqvacrrm3qd"))))
(build-system gnu-build-system)
+ (inputs
+ `(("expat" ,expat)))
(arguments
`(#:phases (alist-cons-before
+ 'configure 'link-expat
+ (lambda _
+ (substitute* "gettext-tools/configure"
+ (("LIBEXPAT=\"-ldl\"") "LIBEXPAT=\"-ldl -lexpat\"")
+ (("LTLIBEXPAT=\"-ldl\"") "LTLIBEXPAT=\"-ldl -lexpat\"")))
+ (alist-cons-before
'check 'patch-tests
(lambda* (#:key inputs #:allow-other-keys)
(let ((bash (which "sh")))
@@ -48,7 +57,7 @@
"posix_spawn")
(("/bin/sh")
bash))))
- %standard-phases)))
+ %standard-phases))))
(home-page "http://www.gnu.org/software/gettext/")
(synopsis "Tools and documentation for translation")
(description