summaryrefslogtreecommitdiff
path: root/gnu/packages/gettext.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-01-06 16:26:09 +0100
committerLudovic Courtès <ludo@gnu.org>2022-01-06 16:27:31 +0100
commita21590dabfcef0aa008503ea981364b90750b07c (patch)
tree88b7bfec9eafe8246ad0a1b1d25025276c92a218 /gnu/packages/gettext.scm
parent495ac045a3ced3fe1b0ae888738b08be9c3fc968 (diff)
downloadguix-patches-a21590dabfcef0aa008503ea981364b90750b07c.tar
guix-patches-a21590dabfcef0aa008503ea981364b90750b07c.tar.gz
gnu: gettext: Work around Gnulib test failures on armhf-linux.
* gnu/packages/gettext.scm (gettext-minimal)[arguments]: In 'patch-tests' phase, conditionally apply "coreutils-gnulib-tests.patch" on ARMv7.
Diffstat (limited to 'gnu/packages/gettext.scm')
-rw-r--r--gnu/packages/gettext.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/gettext.scm b/gnu/packages/gettext.scm
index b75c20c751..d5fd197922 100644
--- a/gnu/packages/gettext.scm
+++ b/gnu/packages/gettext.scm
@@ -111,6 +111,15 @@
(("/bin/pwd")
"pwd"))
+ ;; Work around Gnulib test failures on armhf-linux.
+ #$@(if (target-arm32?)
+ #~((with-directory-excursion "gettext-tools"
+ (invoke "patch" "--force" "-p1" "-i"
+ #$(local-file
+ (search-patch
+ "coreutils-gnulib-tests.patch")))))
+ '())
+
#t)))))
;; When tests fail, we want to know the details.