summaryrefslogtreecommitdiff
path: root/gnu/packages/gettext.scm
diff options
context:
space:
mode:
authorAlex Kost <alezost@gmail.com>2016-09-25 10:43:17 +0300
committerAlex Kost <alezost@gmail.com>2016-09-28 17:54:50 +0300
commit9e01589469abd89e035450d29026f0e14add6801 (patch)
tree53df7a99e76788f9aa90ac6498c11c14e8a80dcf /gnu/packages/gettext.scm
parentb94a6ca074f00b3f769933d074853d3c3ca50d00 (diff)
downloadguix-patches-9e01589469abd89e035450d29026f0e14add6801.tar
guix-patches-9e01589469abd89e035450d29026f0e14add6801.tar.gz
gnu: gettext: Install Emacs tools.
Fixes <http://bugs.gnu.org/24442>. Reported by Ivan Vilata i Balaguer <ivan@selidor.net>. * gnu/packages/gettext.scm (gnu-gettext)[native-inputs]: Add 'emacs'. [arguments]: Add 'add-emacs-autoloads' phase.
Diffstat (limited to 'gnu/packages/gettext.scm')
-rw-r--r--gnu/packages/gettext.scm18
1 files changed, 17 insertions, 1 deletions
diff --git a/gnu/packages/gettext.scm b/gnu/packages/gettext.scm
index a5767ddedf..26ab6777fe 100644
--- a/gnu/packages/gettext.scm
+++ b/gnu/packages/gettext.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016 Alex Kost <alezost@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -27,9 +28,11 @@
#:use-module (guix build-system gnu)
#:use-module (guix build-system perl)
#:use-module (gnu packages docbook)
+ #:use-module (gnu packages emacs)
#:use-module (gnu packages perl)
#:use-module (gnu packages tex)
- #:use-module (gnu packages xml))
+ #:use-module (gnu packages xml)
+ #:use-module (guix utils))
(define-public gettext-minimal
(package
@@ -103,6 +106,19 @@ translated messages from the catalogs. Nearly all GNU packages use Gettext.")
(package
(inherit gettext-minimal)
(name "gettext")
+ (arguments
+ (substitute-keyword-arguments (package-arguments gettext-minimal)
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (add-after 'install 'add-emacs-autoloads
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; Make 'po-mode' and other things available by default.
+ (with-directory-excursion
+ (string-append (assoc-ref outputs "out")
+ "/share/emacs/site-lisp")
+ (symlink "start-po.el" "gettext-autoloads.el")
+ #t)))))))
+ (native-inputs `(("emacs" ,emacs-minimal))) ; for Emacs tools
(synopsis "Tools and documentation for translation")))
(define-public po4a