summaryrefslogtreecommitdiff
path: root/gnu/packages/gettext.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 17:18:24 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 17:48:25 +0100
commit8394619baceb118df92e355377fd543bb1aa501a (patch)
tree504f07c2a9f88596a305b59ef45f941062426a52 /gnu/packages/gettext.scm
parentaca2defe0172868295941fd9f0e97886f6e9b2d4 (diff)
downloadguix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar
guix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar.gz
gnu: Simplify package inputs.
This commit was obtained by running: ./pre-inst-env guix style without any additional argument.
Diffstat (limited to 'gnu/packages/gettext.scm')
-rw-r--r--gnu/packages/gettext.scm44
1 files changed, 21 insertions, 23 deletions
diff --git a/gnu/packages/gettext.scm b/gnu/packages/gettext.scm
index a71af5bbe3..e20d4d1427 100644
--- a/gnu/packages/gettext.scm
+++ b/gnu/packages/gettext.scm
@@ -64,13 +64,12 @@
(outputs '("out"
"doc")) ;9 MiB of HTML
(inputs
- `(("libunistring" ,libunistring)
- ("libxml2" ,libxml2)
-
- ;; TODO: ncurses is only needed for the 'libtextstyle' library.
- ;; The next version of gettext can use a separate libtextstyle,
- ;; but for now we include it here in 'gettext-minimal'.
- ("ncurses" ,ncurses)))
+ (list libunistring
+ libxml2
+ ;; TODO: ncurses is only needed for the 'libtextstyle' library.
+ ;; The next version of gettext can use a separate libtextstyle,
+ ;; but for now we include it here in 'gettext-minimal'.
+ ncurses))
(arguments
`(#:configure-flags '("--with-included-libunistring=no"
"--with-included-libxml=no")
@@ -199,22 +198,21 @@ color, font attributes (weight, posture), or underlining.")
(base32 "0kgbm0af7jwpfspa2xxiy9nc2l1r2s1rhbhz4r229zcqv49ak6sq"))))
(build-system python-build-system)
(native-inputs
- `(("python-bump2version" ,python-bump2version)
- ("python-flake8" ,python-flake8)
- ("python-flake8-implicit-str-concat" ,python-flake8-implicit-str-concat)
- ("python-flake8-print" ,python-flake8-print)
- ("python-isort" ,python-isort)
- ("python-pre-commit" ,python-pre-commit)
- ("python-pytest" ,python-pytest)
- ("python-pytest-cov" ,python-pytest-cov)
- ("python-sphinx" ,python-sphinx)
- ("python-sphinx-argparse" ,python-sphinx-argparse)
- ("python-sphinx-rtd-theme" ,python-sphinx-rtd-theme)
- ("python-twine" ,python-twine)
- ("python-yamllint" ,python-yamllint)))
+ (list python-bump2version
+ python-flake8
+ python-flake8-implicit-str-concat
+ python-flake8-print
+ python-isort
+ python-pre-commit
+ python-pytest
+ python-pytest-cov
+ python-sphinx
+ python-sphinx-argparse
+ python-sphinx-rtd-theme
+ python-twine
+ python-yamllint))
(propagated-inputs
- `(("python-polib" ,python-polib)
- ("python-pymd4c" ,python-pymd4c)))
+ (list python-polib python-pymd4c))
(home-page "https://github.com/mondeja/mdpo")
(synopsis "Markdown file translation utilities using pofiles")
(description
@@ -296,7 +294,7 @@ from Markdown files.")
("perl-yaml-tiny" ,perl-yaml-tiny)
("texlive" ,texlive-tiny)))
(inputs
- `(("perl-pod-parser" ,perl-pod-parser)))
+ (list perl-pod-parser))
(home-page "https://po4a.org/")
(synopsis "Scripts to ease maintenance of translations")
(description