summaryrefslogtreecommitdiff
path: root/gnu/packages/gettext.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-03-26 11:00:46 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-03-26 11:06:46 +0200
commit727bec13a35049f5f819a6f22d93e38aa44220b2 (patch)
tree3b0ffb518e15744805aa5918b9cc30d5ffa18b42 /gnu/packages/gettext.scm
parent23bd8f556e3a7b84f35f8b58ee506241b9b95fca (diff)
downloadguix-patches-727bec13a35049f5f819a6f22d93e38aa44220b2.tar
guix-patches-727bec13a35049f5f819a6f22d93e38aa44220b2.tar.gz
gnu: po4a: Make manpages writable before resetting timestamps.
* gnu/packages/gettext.scm (po4a)[arguments]: Add 'make-compressed-files-writable' phase.
Diffstat (limited to 'gnu/packages/gettext.scm')
-rw-r--r--gnu/packages/gettext.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/gettext.scm b/gnu/packages/gettext.scm
index 26ab6777fe..0de6be07c6 100644
--- a/gnu/packages/gettext.scm
+++ b/gnu/packages/gettext.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Alex Kost <alezost@gmail.com>
+;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -160,7 +161,14 @@ translated messages from the catalogs. Nearly all GNU packages use Gettext.")
(wrap-program file
`("PERL5LIB" ":" prefix (,path))))
(find-files bin "\\.*$"))
- #t))))))
+ #t)))
+ (add-before 'reset-gzip-timestamps 'make-compressed-files-writable
+ (lambda* (#:key outputs #:allow-other-keys)
+ (for-each make-file-writable
+ (find-files (string-append (assoc-ref outputs "out")
+ "/share/man")
+ ".*\\.gz$"))
+ #t)))))
(native-inputs
`(("gettext" ,gettext-minimal)
("perl-module-build" ,perl-module-build)