summaryrefslogtreecommitdiff
path: root/gnu/packages/gettext.scm
diff options
context:
space:
mode:
authorAndy Wingo <wingo@pobox.com>2015-04-05 10:22:28 +0200
committerLudovic Courtès <ludo@gnu.org>2015-04-05 23:18:53 +0200
commit4aaad09db1a95a720562633046e08e5f7b4f684d (patch)
tree42d1ef947cea71e682b12bf3832689e95e2dfdd1 /gnu/packages/gettext.scm
parent29ec55ee27f9127eacc9432741998e585564468e (diff)
downloadguix-patches-4aaad09db1a95a720562633046e08e5f7b4f684d.tar
guix-patches-4aaad09db1a95a720562633046e08e5f7b4f684d.tar.gz
gnu: gettext: Link explicitly to libexpat, again.
* gnu/packages/gettext.scm (gnu-gettext): Re-enable patch from 0e4e4b1329bcf881620f230fda60b6b63d1f8356 to explictly link to libexpat. Otherwise libexpat was searched at runtime via dlopen, which obviously doesn't work in a Guix context. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/gettext.scm')
-rw-r--r--gnu/packages/gettext.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/gettext.scm b/gnu/packages/gettext.scm
index 27b5fb5f55..3a96cd613c 100644
--- a/gnu/packages/gettext.scm
+++ b/gnu/packages/gettext.scm
@@ -70,7 +70,15 @@
(substitute* "gettext-tools/src/project-id"
(("/bin/pwd")
"pwd")))))
- %standard-phases)
+ (alist-cons-before
+ 'configure 'link-expat
+ (lambda _
+ ;; Gettext defaults to opening expat via dlopen on
+ ;; "Linux". Change to link directly.
+ (substitute* "gettext-tools/configure"
+ (("LIBEXPAT=\"-ldl\"") "LIBEXPAT=\"-ldl -lexpat\"")
+ (("LTLIBEXPAT=\"-ldl\"") "LTLIBEXPAT=\"-ldl -lexpat\"")))
+ %standard-phases))
;; When tests fail, we want to know the details.
#:make-flags '("VERBOSE=yes")))