summaryrefslogtreecommitdiff
path: root/gnu/packages/gettext.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-07-08 00:13:15 +0200
committerLudovic Courtès <ludo@gnu.org>2013-07-08 00:13:15 +0200
commit2c9143a1f37ee9fdc2fc03c42f07d4b1eb9eada7 (patch)
tree6d538d767197e14498c67ec2ac93d952695ed1c8 /gnu/packages/gettext.scm
parentacf428dd0bbf590f01c32dd9c63f2dfc3d474eee (diff)
downloadguix-patches-2c9143a1f37ee9fdc2fc03c42f07d4b1eb9eada7.tar
guix-patches-2c9143a1f37ee9fdc2fc03c42f07d4b1eb9eada7.tar.gz
gnu: gettext: Upgrade to 0.18.3.
* gnu/packages/gettext.scm (gettext): Upgrade to 0.18.3. Remove patch. Change `patch-tests' phase to use (which "sh'); keep it regardless of whether we're cross compiling.
Diffstat (limited to 'gnu/packages/gettext.scm')
-rw-r--r--gnu/packages/gettext.scm53
1 files changed, 22 insertions, 31 deletions
diff --git a/gnu/packages/gettext.scm b/gnu/packages/gettext.scm
index c838f9c0a6..399d96784c 100644
--- a/gnu/packages/gettext.scm
+++ b/gnu/packages/gettext.scm
@@ -26,39 +26,30 @@
(define-public gettext
(package
(name "gettext")
- (version "0.18.1.1")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://gnu/gettext/gettext-"
- version ".tar.gz"))
- (sha256
- (base32
- "1sa3ch12qxa4h3ya6hkz119yclcccmincl9j20dhrdx5mykp3b4k"))))
+ (version "0.18.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/gettext/gettext-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0j7rp56c61j4k1bz1xdc041hzv7186yyzhbp95fmc0zq7l2c3wrn"))))
(build-system gnu-build-system)
(arguments
- `(#:patches (list (assoc-ref %build-inputs "patch/gets"))
- #:phases ,(if (%current-target-system)
- '%standard-phases
- '(alist-cons-before
- 'check 'patch-tests
- (lambda* (#:key inputs #:allow-other-keys)
- ;; TODO: Use (which "sh").
- (let ((bash (assoc-ref inputs "bash")))
- (substitute* (find-files "gettext-tools/tests"
- "^msgexec-[0-9]")
- (("#![[:blank:]]/bin/sh")
- (format #f "#!~a/bin/sh" bash)))
- (substitute* (find-files "gettext-tools/gnulib-tests"
- "posix_spawn")
- (("/bin/sh")
- (format #f "~a/bin/bash" bash)))))
- %standard-phases))))
- (inputs
- `(("patch/gets"
- ,(search-patch "gettext-gets-undeclared.patch"))))
- (home-page
- "http://www.gnu.org/software/gettext/")
+ `(#:phases (alist-cons-before
+ 'check 'patch-tests
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((bash (which "sh")))
+ (substitute* (find-files "gettext-tools/tests"
+ "^msgexec-[0-9]")
+ (("#![[:blank:]]/bin/sh")
+ (format #f "#!~a" bash)))
+ (substitute* (find-files "gettext-tools/gnulib-tests"
+ "posix_spawn")
+ (("/bin/sh")
+ bash))))
+ %standard-phases)))
+ (home-page "http://www.gnu.org/software/gettext/")
(synopsis "Tools and documentation for translation")
(description
"Usually, programs are written and documented in English, and use