summaryrefslogtreecommitdiff
path: root/gnu/packages/gettext.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-11-20 22:12:49 +0100
committerLudovic Courtès <ludo@gnu.org>2013-11-20 22:12:49 +0100
commit1dba64079c5aaa1fb40e4b1d989f1f06efd6cb63 (patch)
treeaf5bb45a45bfe2b6ac7d9be4a314997fcd50958c /gnu/packages/gettext.scm
parent953ab5030f1ee870944a291f9e8edc491b198969 (diff)
downloadguix-patches-1dba64079c5aaa1fb40e4b1d989f1f06efd6cb63.tar
guix-patches-1dba64079c5aaa1fb40e4b1d989f1f06efd6cb63.tar.gz
gnu: gettext: Rename binding to 'gnu-gettext'.
* gnu/packages/gettext.scm (gettext): Rename to... (gnu-gettext): ... this. This is used to work around the circular dependency introduced in commit c42a4b7, which users with a #:renamer cannot cope with. * gnu/packages/acl.scm, gnu/packages/attr.scm, gnu/packages/cdrom.scm, gnu/packages/fdisk.scm, gnu/packages/gkrellm.scm, gnu/packages/glib.scm, gnu/packages/gnunet.scm, gnu/packages/grub.scm, gnu/packages/linux.scm, gnu/packages/maths.scm, gnu/packages/nano.scm, gnu/packages/parted.scm, gnu/packages/system.scm, gnu/packages/version-control.scm, gnu/packages/vpn.scm, gnu/packages/w3m.scm, gnu/packages/wget.scm: Adjust accordingly.
Diffstat (limited to 'gnu/packages/gettext.scm')
-rw-r--r--gnu/packages/gettext.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/gettext.scm b/gnu/packages/gettext.scm
index 7edbfa023c..6b056055b8 100644
--- a/gnu/packages/gettext.scm
+++ b/gnu/packages/gettext.scm
@@ -24,7 +24,14 @@
#:use-module (guix build-system gnu)
#:use-module (gnu packages xml))
-(define-public gettext
+;; Use that name to avoid clashes with Guile's 'gettext' procedure.
+;;
+;; We used to resort to #:renamer on the user side, but that prevented
+;; circular dependencies involving (gnu packages gettext). This is because
+;; 'resolve-interface' (as of Guile 2.0.9) iterates eagerly over the used
+;; module when there's a #:renamer, and that module may be empty at that point
+;; in case or circular dependencies.
+(define-public gnu-gettext
(package
(name "gettext")
(version "0.18.3.1")