summaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-08 23:52:43 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-11 05:42:38 +0200
commitf4daf2506697d43112126222f5de4f7c46007192 (patch)
treed9741f713d98d6d29ec8768199a92c31de0d1b05 /gnu/packages/geo.scm
parentca72dd2cb52f9de6fb2fd4aff527db22ff438032 (diff)
downloadguix-patches-f4daf2506697d43112126222f5de4f7c46007192.tar
guix-patches-f4daf2506697d43112126222f5de4f7c46007192.tar.gz
gnu: libosmium: Don't use unstable tarball.
* gnu/packages/geo.scm (libosmium)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm16
1 files changed, 8 insertions, 8 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index c7026c4e96..d228b3edf5 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -746,14 +746,14 @@ to create databases that are optimized for rendering/tile/map-services.")
(name "libosmium")
(version "2.14.2")
(source
- (origin
- (method url-fetch)
- (uri (string-append "https://github.com/osmcode/libosmium/archive/v"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "0d9b46qiw7zkw1h9lygjdwqxnbhm3c7v8kydzw9f9f778cyagc94"))))
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/osmcode/libosmium.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "123ri1l0a2b9fljgpwsl7z2w4i3kmgxz79d4ns9z4mwbp8sw0250"))))
(build-system cmake-build-system)
(propagated-inputs
`(("boost" ,boost)