summaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2021-11-17 20:56:39 -0500
committerTimothy Sample <samplet@ngyro.com>2021-11-18 10:10:14 -0500
commite13b18b26ff221ff1a476b7c9e7abd423b956954 (patch)
treee428c11f160db11533cd2e26b5951189bd895900 /gnu/packages/geo.scm
parent07170f6c49502ffc1111b6392b596032ec43f01c (diff)
downloadguix-patches-e13b18b26ff221ff1a476b7c9e7abd423b956954.tar
guix-patches-e13b18b26ff221ff1a476b7c9e7abd423b956954.tar.gz
gnu: gnome-maps: Build with Meson 0.59.
See <https://github.com/mesonbuild/meson/issues/9441>. * gnu/packages/geo.scm (gnome-maps)[arguments]: Use meson-0.59.
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index bd105f7985..f07b5e4b95 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -59,6 +59,7 @@
#:use-module (gnu packages bash)
#:use-module (gnu packages bison)
#:use-module (gnu packages boost)
+ #:use-module (gnu packages build-tools)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
#:use-module (gnu packages curl)
@@ -224,7 +225,8 @@ topology functions.")
"02bdkmb3wyzfrbq726634v4g1hyh9za70cc2ivlbp7zc2n1jgp5c"))))
(build-system meson-build-system)
(arguments
- `(#:glib-or-gtk? #t
+ `(#:meson ,meson-0.59 ;positional arguments error with meson 0.60
+ #:glib-or-gtk? #t
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'skip-gtk-update-icon-cache