summaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-11-17 19:37:03 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2019-12-06 19:38:56 +0100
commitb1414a81367605741a1d18f2a0bcebc784381cf7 (patch)
treeb8fd756b0272dacaa2b5b0e01231960dd2c4b53d /gnu/packages/geo.scm
parent53c9b39850a98585614ed9622f98213155306191 (diff)
downloadguix-patches-b1414a81367605741a1d18f2a0bcebc784381cf7.tar
guix-patches-b1414a81367605741a1d18f2a0bcebc784381cf7.tar.gz
gnu: Add python-maxminddb.
* gnu/packages/geo.scm (python-maxminddb): New variable.
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 7be1ae5777..26d270e4eb 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -1244,3 +1244,26 @@ format is a custom, but open, binary format designed to facilitate fast
lookups of IP addresses while allowing flexibility in the type of data
associated with an address.")
(license license:asl2.0)))
+
+(define-public python-maxminddb
+ (package
+ (name "python-maxminddb")
+ (version "1.5.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "maxminddb" version))
+ (sha256
+ (base32
+ "0y9giw81k4wdmpryr4k42w50z292mf364a6vs1vxf83ksc9ig6j4"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f)) ;; Tests require a copy of the maxmind database
+ (inputs
+ `(("libmaxminddb" ,libmaxminddb)))
+ (home-page "http://www.maxmind.com/")
+ (synopsis "Reader for the MaxMind DB format")
+ (description "MaxMind DB is a binary file format that stores data indexed
+by IP address subnets (IPv4 or IPv6). This is a Python module for reading
+MaxMind DB files.")
+ (license license:asl2.0)))