summaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-05-17 23:55:58 -0300
committerBjörn Höfling <bjoern.hoefling@bjoernhoefling.de>2021-06-23 06:45:20 +0200
commitac8fb4b9f4db0cf774799b95fc176c8a80ade6cc (patch)
tree9a3066c5598ad746aa7f2bef136c7a32d70828cc /gnu/packages/geo.scm
parent828ceee7db0ab74786049600108d6b15017851c5 (diff)
downloadguix-patches-ac8fb4b9f4db0cf774799b95fc176c8a80ade6cc.tar
guix-patches-ac8fb4b9f4db0cf774799b95fc176c8a80ade6cc.tar.gz
gnu: Add python-pyshp.
* gnu/packages/geo.scm (python-pyshp): New variable.
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index a0b43308e4..af1ed3da96 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -15,6 +15,7 @@
;;; Copyright © 2020 Christopher Baines <mail@cbaines.net>
;;; Copyright © 2020, 2021 Felix Gruber <felgru@posteo.net>
;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
+;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -881,6 +882,37 @@ utilities for data translation and processing.")
`(("gdal" ,gdal)))
(synopsis "GDAL (Geospatial Data Abstraction Library) python bindings")))
+(define-public python-pyshp
+ (package
+ (name "python-pyshp")
+ (version "2.1.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/GeospatialPython/pyshp")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0jsraqzq82pw19wvx84x7w5cs8agr44a9b5y0jjw540wim4xa73r"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ ;; This is the only test file.
+ (invoke "python" "-m" "pytest" "test_shapefile.py")))))))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)
+ ("python-pytest-runner" ,python-pytest-runner)))
+ (home-page "https://github.com/GeospatialPython/pyshp")
+ (synopsis "Read/write support for ESRI Shapefile format")
+ (description
+ "The Python Shapefile Library (PyShp) reads and writes ESRI Shapefiles.")
+ (license license:expat)))
+
(define-public postgis
(package
(name "postgis")