summaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2019-07-20 22:39:33 +0800
committer宋文武 <iyzsong@member.fsf.org>2019-07-21 21:04:38 +0800
commita18a27be9f6f6f43cc5909d55712058031de4831 (patch)
tree8771ae82bcef2ac60f04ea38878ab0a2cdc9d075 /gnu/packages/geo.scm
parente6df9c7e85ea48765c152b27c88ba30c50c92bb2 (diff)
downloadguix-patches-a18a27be9f6f6f43cc5909d55712058031de4831.tar
guix-patches-a18a27be9f6f6f43cc5909d55712058031de4831.tar.gz
gnu: Add python-gdal.
For <https://issues.guix.gnu.org/issue/36623>, thank to Arne Babenhauserheide for the original patch. * gnu/packages/geo.scm (python-gdal): New package.
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index e4b6a262c7..8005c46129 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -604,6 +604,25 @@ utilities for data translation and processing.")
;; frmts/mrf/libLERC
license:asl2.0))))
+(define-public python-gdal
+ (package (inherit gdal)
+ (name "python-gdal")
+ (build-system python-build-system)
+ (arguments
+ '(#:tests? #f ; no tests
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'chdir
+ (lambda _
+ (chdir "swig/python")
+ #t)))))
+ (native-inputs '())
+ (propagated-inputs
+ `(("python-numpy" ,python-numpy)))
+ (inputs
+ `(("gdal" ,gdal)))
+ (synopsis "GDAL (Geospatial Data Abstraction Library) python bindings")))
+
(define-public postgis
(package
(name "postgis")