summaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2019-05-03 13:06:03 +0200
committerJulien Lepiller <julien@lepiller.eu>2019-11-13 22:49:08 +0100
commit6dd0e41d43481c10785ef655d48e7d16d0340d73 (patch)
tree93b122764a662d9b2caf20b7f7acb57626fc2ba1 /gnu/packages/geo.scm
parent68a13319aa34898132a2787a281da012d5ad025b (diff)
downloadguix-patches-6dd0e41d43481c10785ef655d48e7d16d0340d73.tar
guix-patches-6dd0e41d43481c10785ef655d48e7d16d0340d73.tar.gz
gnu: Add java-jmapviewer.
* gnu/packages/geo.scm (java-jmapviewer): New variable.
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm38
1 files changed, 37 insertions, 1 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index dfb00c7547..fc0c0527ec 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -6,7 +6,7 @@
;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2018 Joshua Sierles, Nextjournal <joshua@nextjournal.com>
-;;; Copyright © 2018 Julien Lepiller <julien@lepiller.eu>
+;;; Copyright © 2018, 2019 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2019 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2019 Wiktor Żelazny <wzelazny@vurv.cz>
@@ -27,6 +27,7 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages geo)
+ #:use-module (guix build-system ant)
#:use-module (guix build-system cmake)
#:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system gnu)
@@ -1037,3 +1038,38 @@ persisted.
@end itemize
")
(license license:expat)))
+
+(define-public java-jmapviewer
+ (package
+ (name "java-jmapviewer")
+ (version "2.12")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://svn.openstreetmap.org/applications/"
+ "viewer/jmapviewer/releases/" version
+ "/JMapViewer-" version "-Source.zip"))
+ (sha256
+ (base32
+ "08hbqsbs859v4m5d90560fdifavd1apnpz9v9iry1v31dsvy5707"))))
+ (build-system ant-build-system)
+ (native-inputs
+ `(("unzip" ,unzip)))
+ (arguments
+ `(#:build-target "pack"
+ #:tests? #f; No tests
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'clean
+ (lambda* _
+ (invoke "ant" "clean")))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((dir (string-append (assoc-ref outputs "out") "/share/java/")))
+ (mkdir-p dir)
+ (copy-file "JMapViewer.jar" (string-append dir "JMapViewer.jar"))))))))
+ (home-page "https://wiki.openstreetmap.org/wiki/JMapViewer")
+ (synopsis "OSM map integration in Java")
+ (description "JMapViewer is a Java component which allows to easily
+integrate an OSM map view into your Java application. It is maintained as
+an independent project by the JOSM team.")
+ (license license:gpl2)))