summaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-10-16 21:07:06 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-10-16 23:08:33 +0200
commit6c03d15d7d84c00b02efea0a60e91f55f5541b57 (patch)
tree76190f1949cdf679200ae1ed700c895b366a7228 /gnu/packages/geo.scm
parentbcf9732059d4463e136f5f21e2784e4bc3fe6dee (diff)
downloadguix-patches-6c03d15d7d84c00b02efea0a60e91f55f5541b57.tar
guix-patches-6c03d15d7d84c00b02efea0a60e91f55f5541b57.tar.gz
gnu: grass: Fix start-up without python@3 in profile.
* gnu/packages/geo.scm (grass)[arguments]: Rename ‘wrap-python’ phase to ‘python:wrap’. Add ‘wrap-with-python-interpreter’ phase.
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index b094b55c2a..09afa658c7 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -1865,8 +1865,14 @@ track your position right from your laptop.")
(symlink (string-append dir "/lib")
(string-append out "/lib")))
#t))
- (add-after 'install-links 'wrap-python
- (assoc-ref python:%standard-phases 'wrap)))))
+ (add-after 'install-links 'python:wrap
+ (assoc-ref python:%standard-phases 'wrap))
+ (add-after 'python:wrap 'wrap-with-python-interpreter
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (wrap-program (string-append out "/bin/" ,grassxx)
+ `("GRASS_PYTHON" = (,(which "python3"))))
+ #t))))))
(synopsis "GRASS Geographic Information System")
(description
"GRASS (Geographic Resources Analysis Support System), is a Geographic