summaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-05-18 20:54:14 -0300
committerBjörn Höfling <bjoern.hoefling@bjoernhoefling.de>2021-06-23 06:45:21 +0200
commit5ab7fbad27c652bb2a7143995970e8b5886a0cb6 (patch)
treeaa6e230278717a3ef11e6dbcaeab140c81ac23b0 /gnu/packages/geo.scm
parent4b39a6fa14e5b7a4f075d8f980c974560ffc47ad (diff)
downloadguix-patches-5ab7fbad27c652bb2a7143995970e8b5886a0cb6.tar
guix-patches-5ab7fbad27c652bb2a7143995970e8b5886a0cb6.tar.gz
gnu: Add python-cartopy.
* gnu/packages/geo.scm (python-cartopy): New variable.
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm57
1 files changed, 57 insertions, 0 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index af1ed3da96..546be33e55 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -92,6 +92,7 @@
#:use-module (gnu packages pulseaudio)
#:use-module (gnu packages python)
#:use-module (gnu packages python-check)
+ #:use-module (gnu packages python-science)
#:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages qt)
@@ -913,6 +914,62 @@ utilities for data translation and processing.")
"The Python Shapefile Library (PyShp) reads and writes ESRI Shapefiles.")
(license license:expat)))
+(define-public python-cartopy
+ (package
+ (name "python-cartopy")
+ ;; This is a post-release fix that adds build_ext to setup.py.
+ (version "0.19.0.post1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "Cartopy" version))
+ (sha256
+ (base32 "0xnm8z3as3hriivdfd26s6vn5b63gb46x6vxw6gh1mwfm5rlg2sb"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+ (when tests?
+ (add-installed-pythonpath inputs outputs)
+ (invoke "python" "-m" "pytest" "--pyargs" "cartopy"
+ ;; These tests require online data.
+ "-m" "not natural_earth and not network"
+ ;; This one too but it's not marked as such.
+ "-k" "not test_gridliner_labels_bbox_style")))))))
+ (propagated-inputs
+ `(("python-matplotlib" ,python-matplotlib)
+ ("python-numpy" ,python-numpy)
+ ("python-pykdtree" ,python-pykdtree)
+ ("python-pyshp" ,python-pyshp)
+ ("python-scipy" ,python-scipy)
+ ("python-shapely" ,python-shapely)))
+ (inputs
+ `(("geos" ,geos)
+ ("proj" ,proj)))
+ (native-inputs
+ `(("python-cython" ,python-cython)
+ ("python-flufl-lock" ,python-flufl-lock)
+ ("python-pytest" ,python-pytest)))
+ (home-page "https://scitools.org.uk/cartopy/docs/latest/")
+ (synopsis "Cartographic library for visualisation")
+ (description
+ "Cartopy is a Python package designed to make drawing maps for data
+analysis and visualisation easy.
+
+It features:
+
+@itemize
+@item object oriented projection definitions
+@item point, line, polygon and image transformations between projections
+@item integration to expose advanced mapping in Matplotlib with a simple and
+intuitive interface
+@item powerful vector data handling by integrating shapefile reading with
+Shapely capabilities
+@end itemize")
+ (license license:lgpl3+)))
+
(define-public postgis
(package
(name "postgis")