summaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorWiktor Żelazny <wzelazny@vurv.cz>2019-10-04 15:25:16 +0200
committerLudovic Courtès <ludo@gnu.org>2019-11-04 23:35:32 +0100
commit41b4b713f4892918a9a1950acdd89f33b977d143 (patch)
treead253dab0079bdbcee8e7b3b0ce9644b75a3563c /gnu/packages/geo.scm
parenta8e2826e304cabf77d54f4f08d8d5204bff50eeb (diff)
downloadguix-patches-41b4b713f4892918a9a1950acdd89f33b977d143.tar
guix-patches-41b4b713f4892918a9a1950acdd89f33b977d143.tar.gz
gnu: Add libspatialindex.
* gnu/packages/geo.scm (libspatialindex): new variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 5796db3eb9..e49e0b6db6 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2018 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2019 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2019 Wiktor Żelazny <wzelazny@vurv.cz>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -997,3 +998,37 @@ XyGrib is the continuation of the zyGrib software package with a new team of
volunteers.")
(home-page "https://opengribs.org")
(license license:gpl3+)))
+
+(define-public libspatialindex
+ (package
+ (name "libspatialindex")
+ (version "1.8.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://download.osgeo.org/libspatialindex/"
+ "spatialindex-src-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1vxzm7kczwnb6qdmc0hb00z8ykx11zk3sb68gc7rch4vrfi4dakw"))))
+ (build-system gnu-build-system)
+ (home-page "https://libspatialindex.org")
+ (synopsis "Spatial indexing library")
+ (description "The purpose of this library is to provide:
+
+@itemize
+ @item An extensible framework that will support robust spatial indexing
+methods.
+ @item Support for sophisticated spatial queries. Range, point location,
+ nearest neighbor and k-nearest neighbor as well as parametric queries (defined
+by spatial constraints) should be easy to deploy and run.
+ @item Easy to use interfaces for inserting, deleting and updating information.
+ @item Wide variety of customization capabilities. Basic index and storage
+characteristics like the page size, node capacity, minimum fan-out, splitting
+algorithm, etc. should be easy to customize.
+ @item Index persistence. Internal memory and external memory structures
+should be supported. Clustered and non-clustered indices should be easy to be
+persisted.
+@end itemize
+")
+ (license license:expat)))