summaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2021-03-28 10:40:21 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2021-03-29 11:56:05 +0200
commit3eb14c28d57e1e2c1a23e3d3a36e1091e10d5813 (patch)
treeb036aeca2b6110de9e7d14a3b9a6c5d6e5974726 /gnu/packages/geo.scm
parent74a625ebadc5f0cb8ec4b2028e50f04c448b9f69 (diff)
downloadguix-patches-3eb14c28d57e1e2c1a23e3d3a36e1091e10d5813.tar
guix-patches-3eb14c28d57e1e2c1a23e3d3a36e1091e10d5813.tar.gz
gnu: Add librasterlite2.
* gnu/packages/geo.scm (librasterlite2): New variable. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm57
1 files changed, 57 insertions, 0 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 8c98534a4a..d43b1a4e56 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -373,6 +373,63 @@ writing GeoTIFF information tags.")
(license:non-copyleft "file://LICENSE"
"See LICENSE in the distribution.")))))
+(define-public librasterlite2
+ (package
+ (name "librasterlite2")
+ (version "1.1.0-beta1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://www.gaia-gis.it/gaia-sins/librasterlite2-sources/"
+ "librasterlite2-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1x24gqp4hsq97c31ncwxblab0x0863q8v1z42jil7lvsq3glqa7p"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("cairo" ,cairo)
+ ("curl" ,curl)
+ ("freetype" ,freetype)
+ ("freexl" ,freexl)
+ ("giflib" ,giflib)
+ ("libgeotiff" ,libgeotiff)
+ ("libjpeg-turbo" ,libjpeg-turbo)
+ ("libpng" ,libpng)
+ ("librttopo" ,librttopo)
+ ("libspatialite" ,libspatialite)
+ ("libtiff" ,libtiff)
+ ("libwebp" ,libwebp)
+ ("libxml2" ,libxml2)
+ ("lz4" ,lz4)
+ ("minizip" ,minizip)
+ ("openjpeg" ,openjpeg)
+ ("proj" ,proj)
+ ("sqlite" ,sqlite)
+ ("zstd" ,zstd "lib")))
+ (synopsis "Library to work with huge raster coverages using a SpatiaLite")
+ (description
+ "librasterlite2 is a library that stores and retrieves huge raster
+coverages using a SpatiaLite DBMS.")
+ (home-page "https://www.gaia-gis.it/fossil/librasterlite2/index")
+ ;; For the genuine librasterlite-sources holds:
+ ;; Any of the licenses MPL1.1, GPL2+ or LGPL2.1+ may be picked.
+ ;; Files under src/control_points are from GRASS
+ ;; and are licensed under GPL2+ only.
+ ;; src/md5.[ch]: Placed into the public domain by Alexander Peslyak.
+ ;; The tools supporting the library (both rl2tool and wmslite) are
+ ;; licensed under the GPL v3 (or any subsequent version) terms.
+ ;; The test/*.svg files are placed in the public domain, except for
+ ;; test/Car_Yellow.svg which is licensed under the Free Art License 1.3.
+ (license (list license:gpl2+
+ license:gpl3+
+ license:lal1.3
+ license:lgpl2.1+
+ license:mpl1.1
+ license:public-domain))))
+
(define-public librttopo
(package
(name "librttopo")