summaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2018-09-23 22:36:45 +0200
committerJulien Lepiller <julien@lepiller.eu>2018-09-29 12:39:34 +0200
commit3bd7611e4acbffc501f8cabdbf581ffc442ee72a (patch)
treee0b6c491be9df98651c21c7157cca76924807446 /gnu/packages/geo.scm
parentbe7c64ba2d82f6d800ad6577ff8e9e6306071977 (diff)
downloadguix-patches-3bd7611e4acbffc501f8cabdbf581ffc442ee72a.tar
guix-patches-3bd7611e4acbffc501f8cabdbf581ffc442ee72a.tar.gz
gnu: Add imposm3.
* gnu/packages/geo.scm (imposm3): New variable.
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 5641c742b4..c5b5dbcfd0 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -806,3 +806,47 @@ delivered to any client.")
license:bsd-2
license:bsd-3
license:wtfpl2))))
+
+(define-public imposm3
+ (package
+ (name "imposm3")
+ (version "0.6.0-alpha.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/omniscale/imposm3/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "06f0kwmv52yd5m9jlckqxqmkf0cnqy3hamakrvg9lspplyqrds80"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/omniscale/imposm3/cmd/imposm"
+ #:unpack-path "github.com/omniscale"
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'rename-import
+ (lambda _
+ (rename-file (string-append "src/github.com/omniscale/imposm3-" ,version)
+ "src/github.com/omniscale/imposm3")
+ #t))
+ (add-before 'build 'set-version
+ (lambda _
+ (substitute* "src/github.com/omniscale/imposm3/version.go"
+ (("0.0.0-dev") ,version))
+ #t)))))
+ (inputs
+ `(("geos" ,geos)
+ ("leveldb" ,leveldb)))
+ (home-page "https://imposm.org/")
+ (synopsis "OpenStreetMap importer for PostGIS")
+ (description "Imposm is an importer for OpenStreetMap data. It reads PBF
+files and imports the data into PostgreSQL/PostGIS databases. It is designed
+to create databases that are optimized for rendering/tile/map-services.")
+ (license (list
+ license:asl2.0
+ ;; Some dependencies in vendor have different licenses
+ license:expat
+ license:bsd-2
+ license:bsd-3))))