summaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-11-17 23:24:42 +0100
committerLudovic Courtès <ludo@gnu.org>2021-11-17 23:43:14 +0100
commit3a317f7476f8c6012e166ff9f340f861938721c9 (patch)
tree946e398c37912cfc03be7306951ae87bfeb130fa /gnu/packages/geo.scm
parente55547bf70384691712047912c793c517debd2ec (diff)
parent62e707d67caf1dab2af411a69ff8cec4b2dc686e (diff)
downloadguix-patches-3a317f7476f8c6012e166ff9f340f861938721c9.tar
guix-patches-3a317f7476f8c6012e166ff9f340f861938721c9.tar.gz
Merge branch 'master' into core-updates-frozen
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 1fa53deca5..bd105f7985 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -92,6 +92,7 @@
#:use-module (gnu packages protobuf)
#:use-module (gnu packages pulseaudio)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-build)
#:use-module (gnu packages python-check)
#:use-module (gnu packages python-crypto)
#:use-module (gnu packages python-science)
@@ -1458,6 +1459,42 @@ persisted.
")
(license license:expat)))
+(define-public python-rtree
+ (package
+ (name "python-rtree")
+ (version "0.9.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "Rtree" version))
+ (sha256
+ (base32 "0gna530vy6rh76035cqh7i2lx199cvxjrzjczg9rm6k96k5751xy"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'find-libspatialindex
+ (lambda* (#:key inputs #:allow-other-keys)
+ (setenv "SPATIALINDEX_C_LIBRARY"
+ (string-append (assoc-ref inputs "libspatialindex")
+ "/lib/libspatialindex.so"))))
+ (replace 'check
+ (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+ (when tests?
+ (add-installed-pythonpath inputs outputs)
+ (invoke "python" "-m" "pytest")))))))
+ (native-inputs
+ `(("python-numpy" ,python-numpy)
+ ("python-pytest" ,python-pytest)
+ ("python-wheel" ,python-wheel)))
+ (inputs
+ `(("libspatialindex" ,libspatialindex)))
+ (home-page "https://github.com/Toblerity/rtree")
+ (synopsis "R-Tree spatial index for Python GIS")
+ (description
+ "RTree is a Python package with bindings for @code{libspatialindex}.")
+ (license license:expat)))
+
(define-public java-jmapviewer
(package
(name "java-jmapviewer")