summaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2019-07-28 08:49:00 -0400
committerKei Kebreau <kkebreau@posteo.net>2019-07-28 08:59:17 -0400
commit2cf1e37c109c8d03fae75bc84f7012f3afa956e5 (patch)
tree192d59048f1032eef51bdc86adf197250ded4998 /gnu/packages/geo.scm
parentccad0e4d6973da7af8badfb7125f35f7e51eb2d7 (diff)
downloadguix-patches-2cf1e37c109c8d03fae75bc84f7012f3afa956e5.tar
guix-patches-2cf1e37c109c8d03fae75bc84f7012f3afa956e5.tar.gz
gnu: gnome-maps: Update to 3.30.3.1.
* gnu/packages/geo.scm (gnome-maps): Update to 3.30.3.1. [inputs]: Replace gdk-pixbuf with gdk-pixbuf+svg and gnome-online-accounts with gnome-online-accounts:lib. [arguments]: Adjust 'wrap' phase accordingly.
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm17
1 files changed, 11 insertions, 6 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 5dce3f9a58..09ca77e69b 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -108,7 +108,7 @@ topology functions.")
(define-public gnome-maps
(package
(name "gnome-maps")
- (version "3.30.2.1")
+ (version "3.30.3.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -116,7 +116,7 @@ topology functions.")
name "-" version ".tar.xz"))
(sha256
(base32
- "01hqv36j5ji0djq4vl151113bqhh4hpz72d88fm8zds4pdlx7l57"))))
+ "0xqk3yrds0w8bjmpf4jw0370phvm65av82nqrx7fp1648h9nq7xi"))))
(build-system meson-build-system)
(arguments
`(#:glib-or-gtk? #t
@@ -130,8 +130,11 @@ topology functions.")
(assoc-ref inputs "geocode-glib")
"/lib"))
(goa-path (string-append
- (assoc-ref inputs "gnome-online-accounts")
+ (assoc-ref inputs "gnome-online-accounts:lib")
"/lib"))
+ (gdk-pixbuf-path (string-append
+ (assoc-ref inputs "gdk-pixbuf")
+ "/lib"))
(webkitgtk-path (string-append
(assoc-ref inputs "webkitgtk")
"/lib")))
@@ -140,9 +143,11 @@ topology functions.")
;; There seems to be no way to embed the path of
;; libgoa-1.0.so.0, libwebkit2gtk-4.0.so.37,
- ;; libjavascriptcoregtk-4.0.so.18, and libgeocode-glib.so.0
+ ;; libgdk_pixbuf-2.0.so, libjavascriptcoregtk-4.0.so.18, and
+ ;; libgeocode-glib.so.0
`("LD_LIBRARY_PATH" ":" prefix (,goa-path
,webkitgtk-path
+ ,gdk-pixbuf-path
,geocode-glib-path)))
#t))))))
(native-inputs
@@ -158,14 +163,14 @@ topology functions.")
("libsoup" ,libsoup)
("libgweather" ,libgweather)
("libxml2" ,libxml2)
- ("gdk-pixbuf" ,gdk-pixbuf)
+ ("gdk-pixbuf" ,gdk-pixbuf+svg)
("glib-networking" ,glib-networking)
("geoclue" ,geoclue)
("geocode-glib" ,geocode-glib)
("gfbgraph" ,gfbgraph)
("gjs" ,gjs)
("glib" ,glib)
- ("gnome-online-accounts" ,gnome-online-accounts)
+ ("gnome-online-accounts:lib" ,gnome-online-accounts "lib")
("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
("rest" ,rest)
("webkitgtk" ,webkitgtk)))