summaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2021-09-28 06:34:40 +0000
committerLudovic Courtès <ludo@gnu.org>2021-10-12 18:13:29 +0200
commit2a312105f261913163e0e35842b29dc28d32081d (patch)
treed7fafe8d7fc82d4c0203eb8c50023eaafce2ff14 /gnu/packages/geo.scm
parent9101c7bf8eb63762b2231a31a87d830c0a6b8e52 (diff)
downloadguix-patches-2a312105f261913163e0e35842b29dc28d32081d.tar
guix-patches-2a312105f261913163e0e35842b29dc28d32081d.tar.gz
gnu: proj: Update to 7.2.1.
* gnu/packages/geo.scm (proj): Update to 7.2.1. [build-system]: Change to cmake-build-system. [arguments]: Add configure flag to find googletest. [inputs]: Add curl, libjpeg-turbo and libtiff. [native-inputs]: Add googletest. [description]: Consistently call the package Proj, instead of Proj, PROJ or proj. Use @acronym to define CRS. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm28
1 files changed, 17 insertions, 11 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index b37eb633ff..cb6d32628f 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -514,7 +514,7 @@ fully fledged Spatial SQL capabilities.")
(define-public proj
(package
(name "proj")
- (version "6.3.1")
+ (version "7.2.1")
(source
(origin
(method url-fetch)
@@ -522,22 +522,28 @@ fully fledged Spatial SQL capabilities.")
version ".tar.gz"))
(sha256
(base32
- "1y46ij32j9b4x1kjnnlykcwk3kkjwkg44sfc1ziwm3a3g0ki3q3d"))))
- (build-system gnu-build-system)
+ "050apzdn0isxpsblys1shrl9ccli5vd32kgswlgx1imrbwpg915k"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:configure-flags '("-DUSE_EXTERNAL_GTEST=ON")))
(inputs
- `(("sqlite" ,sqlite)))
+ `(("curl" ,curl)
+ ("libjpeg-turbo" ,libjpeg-turbo)
+ ("libtiff" ,libtiff)
+ ("sqlite" ,sqlite)))
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ `(("googletest" ,googletest)
+ ("pkg-config" ,pkg-config)))
(home-page "https://proj.org/")
(synopsis "Coordinate transformation software")
(description
"Proj is a generic coordinate transformation software that transforms
-geospatial coordinates from one coordinate reference system (CRS) to another.
-This includes cartographic projections as well as geodetic transformations.
-PROJ includes command line applications for easy conversion of coordinates
-from text files or directly from user input. In addition, proj also exposes
-an application programming interface that lets developers use the
-functionality of proj in their own software.")
+geospatial coordinates from one @acronym{CRS, coordinate reference system}
+to another. This includes cartographic projections as well as geodetic
+transformations. Proj includes command line applications for easy
+conversion of coordinates from text files or directly from user input.
+In addition, Proj also exposes an application programming interface that
+lets developers use the functionality of Proj in their own software.")
(license (list license:expat
;; src/projections/patterson.cpp
license:asl2.0