summaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-08-11 16:24:03 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-08-11 16:25:06 +0200
commit2113ddb742d908d5c8458e8e916804dfc1f748bf (patch)
tree28e4bd5de9d9ab286c5ea013e79d08cc4d07f689 /gnu/packages/geo.scm
parent07c0b3cea299e4d11adf4e9636a7188be4c32196 (diff)
downloadguix-patches-2113ddb742d908d5c8458e8e916804dfc1f748bf.tar
guix-patches-2113ddb742d908d5c8458e8e916804dfc1f748bf.tar.gz
gnu: libmaxminddb: Cross-compile.
* gnu/packages/geo.scm (libmaxminddb)[arguments]: Use CC-FOR-TARGET. Pass CC as a make flag instead of an environment variable.
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm7
1 files changed, 2 insertions, 5 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 033da1efd1..b9e3f6c872 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -1359,11 +1359,8 @@ ways, and relations) and their metadata tags.")
(base32 "0fd4a4sxiiwzbd5h74wl1ijnb7xybjyybb7q41vdq3w8nk3zdzd5"))))
(build-system gnu-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'configure 'set-cc-to-gcc
- (lambda _
- (setenv "CC" "gcc"))))))
+ `(#:make-flags
+ (list ,(string-append "CC=" (cc-for-target)))))
(native-inputs
`(("perl" ,perl)))
(home-page "https://maxmind.github.io/libmaxminddb/")