summaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2021-03-28 10:40:18 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2021-03-29 11:56:04 +0200
commit109f13c0981b8134c98a2326f22cc837ec523712 (patch)
tree67423cc6d7d0d00e0bf784b8e9538c5990a6c0e4 /gnu/packages/geo.scm
parentfba2fa7ed842a6f75abe12058003bf853e0e9f52 (diff)
downloadguix-patches-109f13c0981b8134c98a2326f22cc837ec523712.tar
guix-patches-109f13c0981b8134c98a2326f22cc837ec523712.tar.gz
gnu: libspatialite: Update dependencies.
* gnu/packages/geo.scm (libspatialite, spatialite-tools): Update dependencies. [inputs]: Replace proj.4 with proj and remove zlib which is not used anymore since libspatialite started using minizip. (libspatialite)[arguments]: Fix regex to not disable more tests than necessary. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm12
1 files changed, 5 insertions, 7 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 97fa83b86b..8c98534a4a 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -442,9 +442,8 @@ writing GeoTIFF information tags.")
("librttopo" ,librttopo)
("libxml2" ,libxml2)
("minizip" ,minizip)
- ("proj.4" ,proj.4)
- ("sqlite" ,sqlite)
- ("zlib" ,zlib)))
+ ("proj" ,proj)
+ ("sqlite" ,sqlite)))
(arguments
`(#:configure-flags
'("--enable-rttopo=yes")
@@ -454,7 +453,7 @@ writing GeoTIFF information tags.")
(add-after 'unpack 'ignore-broken-tests
(lambda _
(substitute* '("test/Makefile.in")
- (("\tcheck_sql_stm.*" all) "\tcheck_multithread$(EXEEXT) \\\n")
+ (("\tcheck_sql_stmt.* (check_sql_.*)" all tiny) (string-append "\t" tiny))
(("(\tch.*) check_v.*ble2.*$" all vt1) (string-append vt1 " \\\n"))
(("\tch.* (check_v.*ble4.*)$" all vt4) (string-append "\t" vt4)))
#t)))))
@@ -1748,10 +1747,9 @@ associated attribute file (@file{.dbf}).")
("libspatialite" ,libspatialite)
("libxml2" ,libxml2)
("minizip" ,minizip)
- ("proj.4" ,proj.4)
+ ("proj" ,proj)
("readosm" ,readosm)
- ("sqlite" ,sqlite)
- ("zlib" ,zlib)))
+ ("sqlite" ,sqlite)))
(synopsis "Collection of command line tools for SpatiaLite")
(description
"@code{spatialite-tools} is a collection of Command Line Interface (CLI)