summaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2019-12-20 21:36:50 +0530
committerArun Isaac <arunisaac@systemreboot.net>2019-12-26 18:54:42 +0530
commit0f05435682de07d6dcd05b19d006ece17145777c (patch)
treee8e519291d479e5cb70759993cc9bbee046b73c8 /gnu/packages/geo.scm
parent1cbe7a3ed63f8bc9d752e0f608603ae072d70468 (diff)
downloadguix-patches-0f05435682de07d6dcd05b19d006ece17145777c.tar
guix-patches-0f05435682de07d6dcd05b19d006ece17145777c.tar.gz
gnu: gdal: Enable ODS format driver.
* gnu/packages/geo.scm (gdal)[inputs]: Add expat. [arguments]: Add --with-expat to #:configure-flags.
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 0103202593..2cf4eb9c6e 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -608,6 +608,7 @@ development.")
(with "--with-libtiff" "libtiff")
(with "--with-geotiff" "libgeotiff")
(with "--with-libz" "zlib")
+ (with "--with-expat" "expat")
"--with-pcre"))
#:phases
(modify-phases %standard-phases
@@ -616,7 +617,8 @@ development.")
(substitute* "frmts/mrf/mrf_band.cpp"
(("\"../zlib/zlib.h\"") "<zlib.h>")))))))
(inputs
- `(("freexl" ,freexl)
+ `(("expat" ,expat)
+ ("freexl" ,freexl)
("geos" ,geos)
("giflib" ,giflib)
("json-c" ,json-c)