summaryrefslogtreecommitdiff
path: root/gnu/packages/genimage.scm
diff options
context:
space:
mode:
authorVincent Legoll <vincent.legoll@gmail.com>2021-01-14 13:58:45 +0100
committerMathieu Othacehe <othacehe@gnu.org>2021-01-22 10:11:45 +0100
commit7c424b3831ce891bd536831a04ff0e38f58fa045 (patch)
treef146966a519816ca33f696fa575c72f4fa4489b5 /gnu/packages/genimage.scm
parent02e5c95db958a434a42c83f19c7f65437776831e (diff)
downloadguix-patches-7c424b3831ce891bd536831a04ff0e38f58fa045.tar
guix-patches-7c424b3831ce891bd536831a04ff0e38f58fa045.tar.gz
gnu: genimage: Use GIT-FILE-NAME.
* gnu/packages/genimage.scm (origin): Use GIT-FILE-NAME. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/genimage.scm')
-rw-r--r--gnu/packages/genimage.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/genimage.scm b/gnu/packages/genimage.scm
index c9ed6258a0..bd77e4dc33 100644
--- a/gnu/packages/genimage.scm
+++ b/gnu/packages/genimage.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2018 Danny Milosavljevic <dannym@scratchpost.org>
+;;; Copyright © 2021 Vincent Legoll <vincent.legoll@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -47,7 +48,7 @@
(uri (git-reference
(url "https://github.com/pengutronix/genimage")
(commit (string-append "v" version))))
- (file-name (string-append name "-" version "-checkout"))
+ (file-name (git-file-name name version))
(sha256
(base32
"15jmh17lvm3jw9c92bjarly7iwhmnfl322d91mprfv10ppb9ip54"))