summaryrefslogtreecommitdiff
path: root/gnu/packages/gdb.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-09-09 23:08:41 +0200
committerLudovic Courtès <ludo@gnu.org>2015-09-09 23:27:10 +0200
commitf19b9b96cda5ff45810f1363ef30df8d163451ad (patch)
tree5832101e9cd089b08d972743a71179539eab16af /gnu/packages/gdb.scm
parentc0a1ea2c7581e10f14077cc176fc553b26ddfd26 (diff)
downloadguix-patches-f19b9b96cda5ff45810f1363ef30df8d163451ad.tar
guix-patches-f19b9b96cda5ff45810f1363ef30df8d163451ad.tar.gz
gnu: gdb: Use 'modify-phases'.
* gnu/packages/gdb.scm (gdb)[arguments]: Use 'modify-phases'.
Diffstat (limited to 'gnu/packages/gdb.scm')
-rw-r--r--gnu/packages/gdb.scm34
1 files changed, 17 insertions, 17 deletions
diff --git a/gnu/packages/gdb.scm b/gnu/packages/gdb.scm
index 165f410bf6..5849831f04 100644
--- a/gnu/packages/gdb.scm
+++ b/gnu/packages/gdb.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;;
;;; This file is part of GNU Guix.
@@ -47,22 +47,22 @@
(build-system gnu-build-system)
(arguments
'(#:tests? #f ; FIXME "make check" fails on single-processor systems.
- #:phases (alist-cons-after
- 'configure 'post-configure
- (lambda _
- (for-each patch-makefile-SHELL
- (find-files "." "Makefile\\.in")))
- (alist-cons-after
- 'install 'post-install
- (lambda* (#:key outputs #:allow-other-keys)
- ;; Like Binutils, GDB installs libbfd and libopcodes.
- ;; However, this leads to collisions when both are
- ;; installed, and really is none of its business,
- ;; conceptually. So remove them.
- (for-each delete-file
- (find-files (assoc-ref outputs "out")
- "^lib(opcodes|bfd)\\.")))
- %standard-phases))))
+ #:phases (modify-phases %standard-phases
+ (add-after
+ 'configure 'post-configure
+ (lambda _
+ (for-each patch-makefile-SHELL
+ (find-files "." "Makefile\\.in"))))
+ (add-after
+ 'install 'post-install
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; Like Binutils, GDB installs libbfd and libopcodes.
+ ;; However, this leads to collisions when both are
+ ;; installed, and really is none of its business,
+ ;; conceptually. So remove them.
+ (for-each delete-file
+ (find-files (assoc-ref outputs "out")
+ "^lib(opcodes|bfd)\\.")))))))
(inputs
`(("expat" ,expat)
("mpfr" ,mpfr)