summaryrefslogtreecommitdiff
path: root/gnu/packages/gdb.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-06-27 12:34:48 +0200
committerMarius Bakke <marius@gnu.org>2020-06-27 12:34:48 +0200
commitc007d868686fc2f9bf02a34150d4f0ac72b1f8d2 (patch)
treec9098d63b73fdfa9eb1e3e93ca2c65aa3a546124 /gnu/packages/gdb.scm
parenta3997b83ff24007d0d3d14ff61e7e91133bd593b (diff)
downloadguix-patches-c007d868686fc2f9bf02a34150d4f0ac72b1f8d2.tar
guix-patches-c007d868686fc2f9bf02a34150d4f0ac72b1f8d2.tar.gz
gnu: gdb@8.2: Inherit from 'gdb-minimal'.
* gnu/packages/gdb.scm (gdb-minimal): Move definition up. (gdb-8.2): Rename to ... (gdb-minimal-8.2): ... this. Inherit from GDB-MINIMAL. * gnu/packages/rust.scm (rust-1.27)[native-inputs]: Adjust for the rename.
Diffstat (limited to 'gnu/packages/gdb.scm')
-rw-r--r--gnu/packages/gdb.scm18
1 files changed, 9 insertions, 9 deletions
diff --git a/gnu/packages/gdb.scm b/gnu/packages/gdb.scm
index 56d37960f7..f2f272cc90 100644
--- a/gnu/packages/gdb.scm
+++ b/gnu/packages/gdb.scm
@@ -122,11 +122,18 @@ the program is running to try to fix bugs. It can be used to debug programs
written in C, C++, Ada, Objective-C, Pascal and more.")
(license gpl3+)))
+(define-public gdb-minimal
+ (package/inherit
+ gdb
+ (name "gdb-minimal")
+ (inputs (fold alist-delete (package-inputs gdb)
+ '("libxml2" "ncurses" "python-wrapper" "source-highlight")))))
+
;; This version of GDB is required by some of the Rust compilers, see
;; <https://bugs.gnu.org/37810>.
-(define-public gdb-8.2
+(define-public gdb-minimal-8.2
(package
- (inherit gdb)
+ (inherit gdb-minimal)
(version "8.2.1")
(source (origin
(method url-fetch)
@@ -135,10 +142,3 @@ written in C, C++, Ada, Objective-C, Pascal and more.")
(sha256
(base32
"00i27xqawjv282a07i73lp1l02n0a3ywzhykma75qg500wll6sha"))))))
-
-(define-public gdb-minimal
- (package/inherit
- gdb
- (name "gdb-minimal")
- (inputs (fold alist-delete (package-inputs gdb)
- '("libxml2" "ncurses" "python-wrapper" "source-highlight")))))