summaryrefslogtreecommitdiff
path: root/gnu/packages/gdb.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-10-18 12:12:21 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-10-18 18:18:27 +0200
commit47dda6e01e51478567e013e3814aaf48143abbc3 (patch)
tree53d648acbe1deb4f54f3ede854baa08d83e18645 /gnu/packages/gdb.scm
parenta5ef1bcd24a53c13d868db786a645b6e0f10aea9 (diff)
downloadguix-patches-47dda6e01e51478567e013e3814aaf48143abbc3.tar
guix-patches-47dda6e01e51478567e013e3814aaf48143abbc3.tar.gz
gnu: rust: Use GDB 8.2 for tests.
* gnu/packages/gdb.scm (gdb-8.2): New public variable. * gnu/packages/rust.scm (rust-1.27)[native-inputs]: Use GDB-8.2 instead of GDB.
Diffstat (limited to 'gnu/packages/gdb.scm')
-rw-r--r--gnu/packages/gdb.scm12
1 files changed, 12 insertions, 0 deletions
diff --git a/gnu/packages/gdb.scm b/gnu/packages/gdb.scm
index 66bdb81a74..81e2892ad2 100644
--- a/gnu/packages/gdb.scm
+++ b/gnu/packages/gdb.scm
@@ -106,6 +106,18 @@ the program is running to try to fix bugs. It can be used to debug programs
written in C, C++, Ada, Objective-C, Pascal and more.")
(license gpl3+)))
+(define-public gdb-8.2
+ (package/inherit
+ gdb-8.3
+ (version "8.2.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/gdb/gdb-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "00i27xqawjv282a07i73lp1l02n0a3ywzhykma75qg500wll6sha"))))))
+
(define-public gdb
;; This is the fixed version that packages depend on. Update it rarely
;; enough to avoid massive rebuilds.