summaryrefslogtreecommitdiff
path: root/gnu/packages/gd.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-01-25 13:03:04 -0500
committerLeo Famulari <leo@famulari.name>2017-01-25 13:37:02 -0500
commitc134959b969303ae0c49a63399e6908c91eaa974 (patch)
tree068ebcadf3509b1f34337be292b3449bc58d185d /gnu/packages/gd.scm
parent4158b1d1231b5c276022e0139a4050c174bd3997 (diff)
downloadguix-patches-c134959b969303ae0c49a63399e6908c91eaa974.tar
guix-patches-c134959b969303ae0c49a63399e6908c91eaa974.tar.gz
gnu: gd: Incorporate grafted changes.
* gnu/packages/gd.scm (gd)[replacement]: Remove field. [source]: Update to 2.2.4. Remove patches 'gd-CVE-2016-7568.patch' and 'gd-CVE-2016-8670.patch'. [arguments]: New field. (gd-2.2.4): Remove variable. * gnu/packages/patches/gd-CVE-2016-7568.patch, gnu/packages/patches/gd-CVE-2016-8670.patch: Delete files. * gnu/local.mk (dist_patch_DATA): Remove them.
Diffstat (limited to 'gnu/packages/gd.scm')
-rw-r--r--gnu/packages/gd.scm46
1 files changed, 14 insertions, 32 deletions
diff --git a/gnu/packages/gd.scm b/gnu/packages/gd.scm
index 713f7ae91e..1c2be119b1 100644
--- a/gnu/packages/gd.scm
+++ b/gnu/packages/gd.scm
@@ -36,12 +36,11 @@
(define-public gd
(package
(name "gd")
- (replacement gd-2.2.4)
;; Note: With libgd.org now pointing to github.com, genuine old
;; tarballs are no longer available. Notably, versions 2.0.x are
;; missing.
- (version "2.2.3")
+ (version "2.2.4")
(source (origin
(method url-fetch)
@@ -50,12 +49,21 @@
version "/libgd-" version ".tar.xz"))
(sha256
(base32
- "0g3xz8jpz1pl2zzmssglrpa9nxiaa7rmcmvgpbrjz8k9cyynqsvl"))
- (patches (search-patches "gd-CVE-2016-7568.patch"
- "gd-CVE-2016-8670.patch"
- "gd-fix-gd2-read-test.patch"
+ "1rp4v7n1dq38b92kl7gkvpvqqkw7nvdfnz6d5kip5klkxfki6zqk"))
+ (patches (search-patches "gd-fix-gd2-read-test.patch"
"gd-fix-tests-on-i686.patch"))))
(build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; This test is known to fail on i686-linux:
+ ;; https://github.com/libgd/libgd/issues/359
+ ;; TODO Replace this substitution with an upstream bug fix.
+ (add-after 'unpack 'disable-failing-test
+ (lambda _
+ (substitute* "tests/gdimagegrayscale/basic.c"
+ (("return gdNumFailures\\(\\)")
+ "return 0")))))))
(native-inputs
`(("pkg-config" ,pkg-config)))
(inputs
@@ -78,32 +86,6 @@ most common applications of GD involve website development.")
"See COPYING file in the distribution."))
(properties '((cpe-name . "libgd")))))
-(define gd-2.2.4
- (package
- (inherit gd)
- (version "2.2.4")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "https://github.com/libgd/libgd/releases/download/"
- "gd-" version "/libgd-" version ".tar.xz"))
- (patches (search-patches "gd-fix-gd2-read-test.patch"
- "gd-fix-tests-on-i686.patch"))
- (sha256
- (base32
- "1rp4v7n1dq38b92kl7gkvpvqqkw7nvdfnz6d5kip5klkxfki6zqk"))))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- ;; This test is known to fail on i686-linux:
- ;; https://github.com/libgd/libgd/issues/359
- ;; TODO Replace this substitution with an upstream bug fix.
- (add-after 'unpack 'disable-failing-test
- (lambda _
- (substitute* "tests/gdimagegrayscale/basic.c"
- (("return gdNumFailures\\(\\)")
- "return 0")))))))))
-
(define-public perl-gd
(package
(name "perl-gd")