summaryrefslogtreecommitdiff
path: root/gnu/packages/gd.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-01-20 09:03:35 -0500
committerLeo Famulari <leo@famulari.name>2017-01-20 10:30:08 -0500
commit3f0603ea653cefa9ff728c2637d3cd0d778b3602 (patch)
tree741389365a733170a9ac295bda7d8ffe35195f65 /gnu/packages/gd.scm
parent2923f3e5b9b4ce0f355fc6d1f7a688e918c95dda (diff)
downloadguix-patches-3f0603ea653cefa9ff728c2637d3cd0d778b3602.tar
guix-patches-3f0603ea653cefa9ff728c2637d3cd0d778b3602.tar.gz
gnu: gd: Replace with gd-2.2.4 [fixes CVE-2016-{6912,9317} and others].
'CHANGELOG.md' in the development repository lists several fixed bugs with potential security implications: https://github.com/libgd/libgd/blob/gd-2.2.4/CHANGELOG.md * gnu/packages/gd.scm (gd)[replacement]: New field. (gd-2.2.4): New variable.
Diffstat (limited to 'gnu/packages/gd.scm')
-rw-r--r--gnu/packages/gd.scm29
1 files changed, 28 insertions, 1 deletions
diff --git a/gnu/packages/gd.scm b/gnu/packages/gd.scm
index 0241a81db9..0f4f3e44be 100644
--- a/gnu/packages/gd.scm
+++ b/gnu/packages/gd.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2013, 2016 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015, 2016 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 Eric Bavier <bavier@member.fsf.org>
-;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2016, 2017 Leo Famulari <leo@famulari.name>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -36,6 +36,7 @@
(define-public gd
(package
(name "gd")
+ (replacement gd-2.2.4)
;; Note: With libgd.org now pointing to github.com, genuine old
;; tarballs are no longer available. Notably, versions 2.0.x are
@@ -77,6 +78,32 @@ most common applications of GD involve website development.")
"See COPYING file in the distribution."))
(properties '((cpe-name . "libgd")))))
+(define gd-2.2.4
+ (package
+ (inherit gd)
+ (version "2.2.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/libgd/libgd/releases/download/"
+ "gd" version "/libgd-" version ".tar.xz"))
+ (patches (search-patches "gd-fix-gd2-read-test.patch"
+ "gd-fix-tests-on-i686.patch"))
+ (sha256
+ (base32
+ "1rp4v7n1dq38b92kl7gkvpvqqkw7nvdfnz6d5kip5klkxfki6zqk"))))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; This test is known to fail on i686-linux:
+ ;; https://github.com/libgd/libgd/issues/359
+ ;; TODO Replace this substitution with an upstream bug fix.
+ (add-after 'unpack 'disable-failing-test
+ (lambda _
+ (substitute* "tests/gdimagegrayscale/basic.c"
+ (("return gdNumFailures\\(\\)")
+ "return 0")))))))))
+
(define-public perl-gd
(package
(name "perl-gd")