summaryrefslogtreecommitdiff
path: root/gnu/packages/gd.scm
diff options
context:
space:
mode:
authorPetter <petter@mykolab.ch>2017-05-02 16:57:52 +0200
committerLudovic Courtès <ludo@gnu.org>2017-05-02 23:41:14 +0200
commit2f3108ad036d5d59d0c8247703ba22adb57638e5 (patch)
tree185532b3425ea6e04f51d99ef8964e6ce07801ce /gnu/packages/gd.scm
parentdcb95c1fc936d74dfdf84b7e59eff66cb99c5a63 (diff)
downloadguix-patches-2f3108ad036d5d59d0c8247703ba22adb57638e5.tar
guix-patches-2f3108ad036d5d59d0c8247703ba22adb57638e5.tar.gz
gnu: Avoid circular dependencies by Perl license.
* guix/licenses.scm (perl-license): New variable. * gnu/packages/bioinformatics.scm: Change (package-license perl) to perl-license. * gnu/packages/compression.scm: Same. * gnu/packages/databases.scm: Same. * gnu/packages/gd.scm: Same. * gnu/packages/language.scm: Same. * gnu/packages/libevent.scm: Same. * gnu/packages/mail.scm: Same. * gnu/packages/messaging.scm: Same. * gnu/packages/ncurses.scm: Same. * gnu/packages/networking.scm: Same. * gnu/packages/photo.scm: Same. * gnu/packages/tcl.scm: Same. * gnu/packages/tex.scm: Same. * gnu/packages/tls.scm: Same. * gnu/packages/web.scm: Same. * gnu/packages/wm.scm: Same. * gnu/packages/xml.scm: Same. * gnu/packages/xorg.scm: Same. * gnu/packages/zip.scm: Same. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/gd.scm')
-rw-r--r--gnu/packages/gd.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/gd.scm b/gnu/packages/gd.scm
index 62c8fd8588..aac0f9664c 100644
--- a/gnu/packages/gd.scm
+++ b/gnu/packages/gd.scm
@@ -32,7 +32,7 @@
#:use-module (gnu packages fontutils)
#:use-module (gnu packages compression)
#:use-module (gnu packages pkg-config)
- #:use-module ((guix licenses) #:select (non-copyleft)))
+ #:use-module ((guix licenses) #:select (non-copyleft perl-license)))
(define-public gd
(package
@@ -139,7 +139,7 @@ most common applications of GD involve website development.")
(description "GD.pm is an autoloadable interface module for libgd, a
popular library for creating and manipulating PNG files. With this library
you can create PNG images on the fly or modify existing files.")
- (license (package-license perl))))
+ (license perl-license)))
(define-public perl-gd-securityimage
(package
@@ -166,4 +166,4 @@ security (captcha) images. The final output is the actual graphic data, the
mime type of the graphic, and the created random string. The module also has
some \"styles\" that are used to create the background (or foreground) of the
image.")
- (license (package-license perl))))
+ (license perl-license)))