summaryrefslogtreecommitdiff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2017-08-06 00:23:20 -0400
committerMark H Weaver <mhw@netris.org>2017-08-06 00:23:20 -0400
commitf167595ba1a4e0e419adc17de6af275bedf32822 (patch)
tree6a582fbda8ad9d72962359add99e5ae219dd030d /gnu/packages/gcc.scm
parente3df6938acc2ba2d2f7333d911b8bdc3697f0f75 (diff)
parent01a61d7040b1794f36547b107abce6e967d59f21 (diff)
downloadguix-patches-f167595ba1a4e0e419adc17de6af275bedf32822.tar
guix-patches-f167595ba1a4e0e419adc17de6af275bedf32822.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 6b1bc762ba..eee91c32bf 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -340,6 +340,7 @@ where the OS part is overloaded to denote a specific ABI---into GCC
for several languages, including C, C++, Objective-C, Fortran, Java, Ada, and
Go. It also includes runtime support libraries for these languages.")
(license gpl3+)
+ (supported-systems (delete "aarch64-linux" %supported-systems))
(home-page "https://gcc.gnu.org/"))))
(define-public gcc-4.8
@@ -352,7 +353,8 @@ Go. It also includes runtime support libraries for these languages.")
(sha256
(base32
"08yggr18v373a1ihj0rg2vd6psnic42b518xcgp3r9k81xz1xyr2"))
- (patches (search-patches "gcc-arm-link-spec-fix.patch"))))))
+ (patches (search-patches "gcc-arm-link-spec-fix.patch"))))
+ (supported-systems %supported-systems)))
(define-public gcc-4.9
(package (inherit gcc-4.7)
@@ -366,7 +368,8 @@ Go. It also includes runtime support libraries for these languages.")
"14l06m7nvcvb0igkbip58x59w3nq6315k6jcz3wr9ch1rn9d44bc"))
(patches (search-patches "gcc-arm-bug-71399.patch"
"gcc-libvtv-runpath.patch"))))
- (native-inputs `(("texinfo" ,texinfo)))))
+ (native-inputs `(("texinfo" ,texinfo)))
+ (supported-systems %supported-systems)))
(define-public gcc-5
;; Note: GCC >= 5 ships with .info files but 'make install' fails to install