summaryrefslogtreecommitdiff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-02-22 13:00:59 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-02-22 13:09:15 +0200
commite4779e061056b1a3a3ab56ef817353d86c482611 (patch)
tree7072348811adcbbe0173b01ed30c0681bd81d9eb /gnu/packages/gcc.scm
parent5cc9d41d86890c6d96b627a34f0f26abc9da6b39 (diff)
downloadguix-patches-e4779e061056b1a3a3ab56ef817353d86c482611.tar
guix-patches-e4779e061056b1a3a3ab56ef817353d86c482611.tar.gz
gnu: custom-gcc-gccgo: Remove procedure.
* gnu/packages/gcc.scm (custom-gcc-gccgo): Remove procedure. (make-gccgo): Use custom-gcc procedure.
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm38
1 files changed, 1 insertions, 37 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index ce62d7533a..1f89915ac8 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -885,42 +885,6 @@ as the 'native-search-paths' field."
(find-files (string-append (assoc-ref outputs "out") "/bin")
".*(c\\+\\+|cpp|g\\+\\+|gcov|gcc|lto)(-.*)?$"))))))))))
-(define* (custom-gcc-gccgo gcc name languages
- #:optional
- (search-paths (package-native-search-paths gcc))
- #:key (separate-lib-output? #t))
- ;; TODO: remove CUSTOM-GCC-GCCGO when regex changes for CUSTOM-GCC are
- ;; merged into master <https://issues.guix.gnu.org/49010>
- "Return a custom version of GCC that supports LANGUAGES. Use SEARCH-PATHS
-as the 'native-search-paths' field."
- (package (inherit gcc)
- (name name)
- (outputs (if separate-lib-output?
- (package-outputs gcc)
- (delete "lib" (package-outputs gcc))))
- (native-search-paths search-paths)
- (properties (alist-delete 'hidden? (package-properties gcc)))
- (arguments
- (substitute-keyword-arguments (package-arguments gcc)
- ((#:modules modules %gnu-build-system-modules)
- `(,@modules
- (srfi srfi-1)
- (srfi srfi-26)
- (ice-9 regex)))
- ((#:configure-flags flags)
- `(cons (string-append "--enable-languages="
- ,(string-join languages ","))
- (remove (cut string-match "--enable-languages.*" <>)
- ,flags)))
- ((#:phases phases)
- `(modify-phases ,phases
- (add-after 'install 'remove-broken-or-conflicting-files
- (lambda* (#:key outputs #:allow-other-keys)
- (for-each
- delete-file
- (find-files (string-append (assoc-ref outputs "out") "/bin")
- ".*(c\\+\\+|cpp|g\\+\\+|gcov|gcc|lto)(-.*)?$"))))))))))
-
(define %generic-search-paths
;; This is the language-neutral search path for GCC. Entries in $CPATH are
;; not considered "system headers", which means GCC can raise warnings for
@@ -992,7 +956,7 @@ misnomer.")))
(define (make-gccgo gcc)
"Return a gccgo package based on GCC."
- (let ((gccgo (custom-gcc-gccgo gcc "gccgo" '("go") %generic-search-paths)))
+ (let ((gccgo (custom-gcc gcc "gccgo" '("go") %generic-search-paths)))
(package
(inherit gccgo)
(synopsis "Go frontend to GCC")