summaryrefslogtreecommitdiff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-02-17 23:34:47 +0100
committerLudovic Courtès <ludo@gnu.org>2018-02-18 00:48:16 +0100
commitd65930708f1a55d9c1ecdb53e189d154902b0f05 (patch)
treeec153dcd4087e8986042f9adec5a494c2f778e1e /gnu/packages/gcc.scm
parenta9d4a9ad332a1568d2abf2e47e68e590f32b386f (diff)
downloadguix-patches-d65930708f1a55d9c1ecdb53e189d154902b0f05.tar
guix-patches-d65930708f1a55d9c1ecdb53e189d154902b0f05.tar.gz
gnu: gcc@4.9: Fix libsanitizer compilation with glibc 2.26.
* gnu/packages/patches/gcc-4.9-libsanitizer-fix.patch: New file. * gnu/packages/gcc.scm (gcc-4.9)[source](patches): Add it. * gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 2c7650d3f1..62b8968823 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014, 2015, 2018 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2014, 2015, 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
@@ -392,7 +392,8 @@ Go. It also includes runtime support libraries for these languages.")
(sha256
(base32
"14l06m7nvcvb0igkbip58x59w3nq6315k6jcz3wr9ch1rn9d44bc"))
- (patches (search-patches "gcc-arm-bug-71399.patch"
+ (patches (search-patches "gcc-4.9-libsanitizer-fix.patch"
+ "gcc-arm-bug-71399.patch"
"gcc-asan-missing-include.patch"
"gcc-libvtv-runpath.patch"
"gcc-fix-texi2pod.patch"))