summaryrefslogtreecommitdiff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
authorCarl Dong <contact@carldong.me>2019-05-05 14:32:57 +0000
committerLudovic Courtès <ludo@gnu.org>2019-05-06 10:18:15 +0200
commitbdfc327639dd613f47fd21f7f809b2ea75b46d5f (patch)
tree50c59aa6de77362d7673586ea2976e9e450e862e /gnu/packages/gcc.scm
parent654332f00fb810f512131d082641a396bc2e25b2 (diff)
downloadguix-patches-bdfc327639dd613f47fd21f7f809b2ea75b46d5f.tar
guix-patches-bdfc327639dd613f47fd21f7f809b2ea75b46d5f.tar.gz
gnu: gcc: Add 9.1.0.
* gnu/packages/gcc.scm (gcc-9): New variable. * gnu/packages/commencement.scm (gcc-toolchain-9): New variable. * gnu/packages/patches/gcc-9-strmov-store-file-names.patch: New file. * gnu/local.mk (dist_patch_DATA): Add the patch. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index b9a9583410..eefce2737b 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -519,6 +519,20 @@ It also includes runtime support libraries for these languages.")))
(patches (search-patches "gcc-8-strmov-store-file-names.patch"
"gcc-5.0-libvtv-runpath.patch"))))))
+(define-public gcc-9
+ (package
+ (inherit gcc-8)
+ (version "9.1.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/gcc/gcc-"
+ version "/gcc-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1817nc2bqdc251k0lpc51cimna7v68xjrnvqzvc50q3ax4s6i9kr"))
+ (patches (search-patches "gcc-9-strmov-store-file-names.patch"
+ "gcc-5.0-libvtv-runpath.patch"))))))
+
;; Note: When changing the default gcc version, update
;; the gcc-toolchain-* definitions and the gfortran definition
;; accordingly.