summaryrefslogtreecommitdiff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-12-08 23:39:00 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-12-09 11:17:45 +0100
commitb69156ef3055bd1bd1cfd6da2c45356403d22226 (patch)
tree82296e64d5494c77b240c03b2e2c8c55c0f299dc /gnu/packages/gcc.scm
parent95a4965f2df99d7dc7e2cd99330b3b27e0e5a947 (diff)
downloadguix-patches-b69156ef3055bd1bd1cfd6da2c45356403d22226.tar
guix-patches-b69156ef3055bd1bd1cfd6da2c45356403d22226.tar.gz
gnu: Add gfortran-7.
* gnu/packages/gcc.scm (gfortran-7): New variable.
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 1dab77d105..f6d18bdcb6 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020, 2021 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014, 2015, 2018 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2014, 2015, 2016, 2017, 2019 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2014, 2015, 2016, 2017, 2019, 2021 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2015, 2016, 2017, 2018, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Carlos Sánchez de La Lama <csanchezdll@gmail.com>
@@ -794,6 +794,12 @@ as the 'native-search-paths' field."
"gfortran" '("fortran")
%generic-search-paths)))
+(define-public gfortran-7
+ (hidden-package
+ (custom-gcc gcc-7
+ "gfortran" '("fortran")
+ %generic-search-paths)))
+
(define-public gdc-10
(hidden-package
(custom-gcc gcc-10 "gdc" '("d")