summaryrefslogtreecommitdiff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
authorThiago Jung Bauermann <bauermann@kolabnow.com>2021-08-05 13:19:43 -0300
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-11 10:31:31 -0500
commitb04a20f77fe3863931de273490d75371561d4e51 (patch)
tree069c2bf37e28078a4c7ce52f45a3e173ccd743b8 /gnu/packages/gcc.scm
parent460d6aca0c9a8f8443d50e5a5cf2bf9841bcc559 (diff)
downloadguix-patches-b04a20f77fe3863931de273490d75371561d4e51.tar
guix-patches-b04a20f77fe3863931de273490d75371561d4e51.tar.gz
gnu: gcc-5: Fix powerpc64le-linux build
GCC 5 has a misaligned access to a vector pointer which causes a build failure when using GCC 8 and later. Backport upstream fix that was applied on the GCC 6 branch. * gnu/packages/gcc.scm (gcc-5)[source]: Apply gcc-5-fix-powerpc64le-build.patch. * gnu/packages/patches/gcc-5-fix-powerpc64le-build.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 4a5f8f0886..1dab77d105 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -490,7 +490,9 @@ Go. It also includes runtime support libraries for these languages.")
"gcc-5-source-date-epoch-2.patch"
"gcc-6-libsanitizer-mode-size.patch"
"gcc-fix-texi2pod.patch"
- "gcc-5-hurd.patch"))
+ "gcc-5-hurd.patch"
+ ;; See https://gcc.gnu.org/bugzilla/show_bug.cgi?id=86162
+ "gcc-5-fix-powerpc64le-build.patch"))
(modules '((guix build utils)))
(snippet gcc-canadian-cross-objdump-snippet)))
(inputs