summaryrefslogtreecommitdiff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-05-08 18:45:39 -0400
committerMark H Weaver <mhw@netris.org>2018-05-08 18:45:39 -0400
commitaedc6e9fc952665e666f2febfc0b37235ad850ff (patch)
tree00d236f54b01e534b97b674673ca1ccd9b3cd18d /gnu/packages/gcc.scm
parent69d5909e032e2fba57814ea9db52389d384d9341 (diff)
parentf1f6f227264999bb362a95e6ec74badcb7de34db (diff)
downloadguix-patches-aedc6e9fc952665e666f2febfc0b37235ad850ff.tar
guix-patches-aedc6e9fc952665e666f2febfc0b37235ad850ff.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 741cfab06e..5012d9a913 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -485,7 +485,17 @@ Go. It also includes runtime support libraries for these languages.")
#t))))
(inputs
`(("isl" ,isl)
- ,@(package-inputs gcc-4.7)))))
+ ,@(package-inputs gcc-4.7)))
+
+ (native-search-paths
+ ;; We have to use 'CPATH' for GCC > 5, not 'C_INCLUDE_PATH' & co., due to
+ ;; <https://gcc.gnu.org/bugzilla/show_bug.cgi?id=70129>.
+ (list (search-path-specification
+ (variable "CPATH")
+ (files '("include")))
+ (search-path-specification
+ (variable "LIBRARY_PATH")
+ (files '("lib" "lib64")))))))
(define-public gcc-7
(package