summaryrefslogtreecommitdiff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2020-09-11 18:07:58 +0200
committerLudovic Courtès <ludo@gnu.org>2020-09-13 23:34:22 +0200
commita4fe16ee41d64bfe9cb9402c29d11d974c235662 (patch)
treea38c7af9c66b99ac12a01b481e4d1ce3d61820f2 /gnu/packages/gcc.scm
parent66ce92ffe43880407ff96477466a8950d1d8603e (diff)
downloadguix-patches-a4fe16ee41d64bfe9cb9402c29d11d974c235662.tar
guix-patches-a4fe16ee41d64bfe9cb9402c29d11d974c235662.tar.gz
gnu: libgccjit: Reword synopsis and description.
Fixes <https://bugs.gnu.org/43303>. Reported by Jeffrey Walton <noloader@gmail.com>. * gnu/packages/gcc.scm: (libgccjit)[synopsis,description]: Reword. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index a39ac3b84c..c74477aed9 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2018, 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2020 Joseph LaFreniere <joseph@lafreniere.xyz>
;;; Copyright © 2020 Guy Fleury Iteriteka <gfleury@disroot.org>
+;;; Copyright © 2020 Simon Tournier <zimon.toutoune@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -759,7 +760,16 @@ as the 'native-search-paths' field."
(for-each delete-file
(find-files (string-append (assoc-ref outputs "out") "/bin")
".*(c\\+\\+|cpp|g\\+\\+|gcov|gcc|gcc-.*)"))
- #t))))))))
+ #t))))))
+ (synopsis "GCC library generating machine code on-the-fly at runtime")
+ (description
+ "This package is part of the GNU Compiler Collection and provides an
+embeddable library for generating machine code on-the-fly at runtime. This
+shared library can then be dynamically-linked into bytecode interpreters and
+other such programs that want to generate machine code on-the-fly at run-time.
+It can also be used for ahead-of-time code generation for building standalone
+compilers. The just-in-time (jit) part of the name is now something of a
+misnomer.")))
(define-public gccgo-4.9