summaryrefslogtreecommitdiff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
authorAlex Vong <alexvong1995@gmail.com>2018-06-14 01:29:08 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2018-06-14 01:30:44 +0200
commita1a3b25dfe9ca3621d894b337c4b5fcef10ddc8f (patch)
tree720877eadde240d24112d70875234daae095fc19 /gnu/packages/gcc.scm
parenta8ef66f94d06087a7f9a6531e41f4395397921e3 (diff)
downloadguix-patches-a1a3b25dfe9ca3621d894b337c4b5fcef10ddc8f.tar
guix-patches-a1a3b25dfe9ca3621d894b337c4b5fcef10ddc8f.tar.gz
gnu: custom-gcc: Fix regex used for matching executables.
Fixes <https://bugs.gnu.org/31561>. * gnu/packages/gcc.scm (custom-gcc)[arguments]: Fix regex used for matching broken or conflicting executables. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 5012d9a913..130c212669 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -612,7 +612,7 @@ as the 'native-search-paths' field."
(lambda* (#:key outputs #:allow-other-keys)
(for-each delete-file
(find-files (string-append (assoc-ref outputs "out") "/bin")
- ".*(c\\+\\+|cpp|g\\+\\+|gcov|gcc.*)"))
+ ".*(c\\+\\+|cpp|g\\+\\+|gcov|gcc|gcc-.*)"))
#t))))))))
(define %generic-search-paths