summaryrefslogtreecommitdiff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-01-02 14:42:56 +0100
committerLudovic Courtès <ludo@gnu.org>2017-01-02 14:54:24 +0100
commit9af076245f2e9e708314e4267c2f7c732aaff3b2 (patch)
tree0bd85dec6ca693896ad2ee4d78d84e8ccf69da24 /gnu/packages/gcc.scm
parent1b5ea0922f0e779dcd29c6a8fe1f6951ba3b2a43 (diff)
downloadguix-patches-9af076245f2e9e708314e4267c2f7c732aaff3b2.tar
guix-patches-9af076245f2e9e708314e4267c2f7c732aaff3b2.tar.gz
gnu: gfortran: Remove non-'eq?' duplicate of gfortran@4.9.
* gnu/packages/gcc.scm (gfortran): Turn into an alias for GFORTRAN-4.9.
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 0f3f36e7d9..cfd33f85ab 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2014, 2015, 2016 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
@@ -494,8 +494,11 @@ as the 'native-search-paths' field."
%generic-search-paths))
(define-public gfortran
- (custom-gcc gcc "gfortran" '("fortran")
- %generic-search-paths))
+ ;; Note: Update this when GCC changes! We cannot use
+ ;; (custom-gcc gcc "fortran" …) because that would lead to a package object
+ ;; that is not 'eq?' with GFORTRAN-4.9, and thus 'fold-packages' would
+ ;; report two gfortran@4.9 that are in fact identical.
+ gfortran-4.9)
(define-public gfortran-5
(custom-gcc gcc-5 "gfortran" '("fortran")