summaryrefslogtreecommitdiff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-05-07 12:02:23 +0200
committerLudovic Courtès <ludo@gnu.org>2018-05-07 12:02:23 +0200
commit91a56b4ab5e714e230c0088fb9f5ce0519efe1a0 (patch)
tree3c1773814036f52134b9cf4a60bcdd3ca73a93eb /gnu/packages/gcc.scm
parentb992bfea7491795f540a43bb3b5233d7ebfac8c8 (diff)
downloadguix-patches-91a56b4ab5e714e230c0088fb9f5ce0519efe1a0.tar
guix-patches-91a56b4ab5e714e230c0088fb9f5ce0519efe1a0.tar.gz
gnu: gcc > 5: Use 'CPATH' instead of 'C_INCLUDE_PATH' & co.
Partly addresses <https://bugs.gnu.org/30756>. Reported by julien lepiller <julien@lepiller.eu>, Marius Bakke <mbakke@fastmail.com>, and Giel van Schijndel <giel@mortis.eu> * gnu/packages/gcc.scm (gcc-6)[native-search-paths]: New field.
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 62b8968823..ba2fce6d37 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -476,7 +476,17 @@ Go. It also includes runtime support libraries for these languages.")
"pa" "sh" "tilepro" "xtensa")))))
(inputs
`(("isl" ,isl)
- ,@(package-inputs gcc-4.7)))))
+ ,@(package-inputs gcc-4.7)))
+
+ (native-search-paths
+ ;; We have to use 'CPATH' for GCC > 5, not 'C_INCLUDE_PATH' & co., due to
+ ;; <https://gcc.gnu.org/bugzilla/show_bug.cgi?id=70129>.
+ (list (search-path-specification
+ (variable "CPATH")
+ (files '("include")))
+ (search-path-specification
+ (variable "LIBRARY_PATH")
+ (files '("lib" "lib64")))))))
(define-public gcc-7
(package