summaryrefslogtreecommitdiff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-03-24 15:42:16 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-03-24 20:57:28 +0200
commit8f0cd6575dc2f933a86b8b0a3d193813712b1ff0 (patch)
treee116b4707baefe1b6d2bf5b560f76c3aa67949dd /gnu/packages/gcc.scm
parent0e2b817732539c496d3310e42eb4ea5340e8e570 (diff)
downloadguix-patches-8f0cd6575dc2f933a86b8b0a3d193813712b1ff0.tar
guix-patches-8f0cd6575dc2f933a86b8b0a3d193813712b1ff0.tar.gz
gnu: gcc-4.7: Unconditionally apply powerpc substitution.
* gnu/packages/gcc.scm (gcc-4.7)[arguments]: Adjust 'pre-configure phase to always apply powerpc substitution.
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm11
1 files changed, 4 insertions, 7 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 061bd86261..b64f933191 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -274,13 +274,10 @@ where the OS part is overloaded to denote a specific ABI---into GCC
~a"
libc line))))
- ;; TODO: Make this unconditional in core-updates.
- ,@(if (target-powerpc?)
- `((when (file-exists? "gcc/config/rs6000")
- ;; Force powerpc libdir to be /lib and not /lib64
- (substitute* (find-files "gcc/config/rs6000")
- (("/lib64") "/lib"))))
- `())
+ (when (file-exists? "gcc/config/rs6000")
+ ;; Force powerpc libdir to be /lib and not /lib64
+ (substitute* (find-files "gcc/config/rs6000")
+ (("/lib64") "/lib")))
;; Don't retain a dependency on the build-time sed.
(substitute* "fixincludes/fixincl.x"