summaryrefslogtreecommitdiff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
authorCarl Dong <contact@carldong.me>2021-05-28 16:23:01 -0400
committerCarl Dong <contact@carldong.me>2021-06-14 12:29:11 -0400
commit83d9e2ee56cb0ca2a644074ad232503e25ac7116 (patch)
treefe455c74478765f447366cbb9d1df687e8f7ee36 /gnu/packages/gcc.scm
parent209da4fce663c739cdc1ef146185a917849079fa (diff)
downloadguix-patches-83d9e2ee56cb0ca2a644074ad232503e25ac7116.tar
guix-patches-83d9e2ee56cb0ca2a644074ad232503e25ac7116.tar.gz
gnu: gcc-8: Make static libs reproducible
This fixes the nonreproducibility in gcc documented here: https://reproducible-builds.org/docs/archives/#gnu-libtool * gnu/packages/patches/gcc-8-sort-libtool-find-output.patch: New patch. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/gcc.scm (gcc-8)[source]: Apply it.
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 1fd5710e57..0a394615b5 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -563,7 +563,8 @@ It also includes runtime support libraries for these languages.")))
(base32
"0l7d4m9jx124xsk6xardchgy2k5j5l2b15q322k31f0va4d8826k"))
(patches (search-patches "gcc-8-strmov-store-file-names.patch"
- "gcc-5.0-libvtv-runpath.patch"))))))
+ "gcc-5.0-libvtv-runpath.patch"
+ "gcc-8-sort-libtool-find-output.patch"))))))
(define-public gcc-9
(package